summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-09-29 11:48:41 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-09-29 11:51:54 +0200
commita3fe9ecbce7d7333ee40c9933e4198b17886a8a7 (patch)
treedb905ae9e590993bccabc976e8e7c749dbd89724 /app-shells
parentmedia-libs/netpbm: drop 11.7.1 (diff)
downloadgentoo-a3fe9ecbce7d7333ee40c9933e4198b17886a8a7.tar.gz
gentoo-a3fe9ecbce7d7333ee40c9933e4198b17886a8a7.tar.bz2
gentoo-a3fe9ecbce7d7333ee40c9933e4198b17886a8a7.zip
app-shells/atuin: only create shell-init file if USE=client
Closes: https://bugs.gentoo.org/940444 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/atuin/atuin-18.3.0-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-shells/atuin/atuin-18.3.0-r1.ebuild b/app-shells/atuin/atuin-18.3.0-r1.ebuild
index 6f383e0b5123..584ccab1160b 100644
--- a/app-shells/atuin/atuin-18.3.0-r1.ebuild
+++ b/app-shells/atuin/atuin-18.3.0-r1.ebuild
@@ -520,6 +520,10 @@ src_compile() {
|| die
done
+ if ! use client; then
+ return 0
+ fi
+
mkdir shell-init || die
for shell in bash fish zsh; do
"${ATUIN_BIN}" init ${shell} > shell-init/${shell} || die
@@ -575,6 +579,10 @@ src_install() {
dozshcomp "completions/_${PN}"
dofishcomp "completions/${PN}.fish"
+ if ! use client; then
+ return 0
+ fi
+
insinto "/usr/share/${PN}"
doins -r shell-init