summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-12-19 16:05:02 +0200
committerMart Raudsepp <leio@gentoo.org>2020-12-19 17:13:45 +0200
commit39d2b03df4e3593061d1af85b7c0381d93aefb9a (patch)
tree4a374eb03ced36ff291018a123ff064eafe1884b /app-text/gspell
parentgnome-extra/gnome-user-docs: bump to 3.36.6 (diff)
downloadgentoo-39d2b03df4e3593061d1af85b7c0381d93aefb9a.tar.gz
gentoo-39d2b03df4e3593061d1af85b7c0381d93aefb9a.tar.bz2
gentoo-39d2b03df4e3593061d1af85b7c0381d93aefb9a.zip
app-text/gspell: bump to 1.8.4
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.8.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index a1c7fbf09305..4c02f8a25923 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,2 +1,3 @@
DIST gspell-1.6.1.tar.xz 416704 BLAKE2B 2a180bc52d3f09813d8de362e5bf900f831663c09530c8a9b993baf55f852a3939447a71c9c9dc0caafba7e8b74a2a5aad4443cf248eb87da4e15e0481e74262 SHA512 f1ffbd0d23d9743bcf924c25b3a3d7bf93c6a5e4ea5e362fb7300f657d8c1d0117e847f3dec29de377947f850e003b24a3231e88e99b313c955dd94ce358c23e
DIST gspell-1.8.3.tar.xz 421468 BLAKE2B 70a8c0649a9f1f0d5e1bbc170734c6ce7aeb4875ed1cca52c4c582688c56553ad2363b9fed732c504f3ff6bc33d994fc4ba12cd3754e4f3b602be2a2015144df SHA512 4116231fdfb416e70ee34c73e0ecf81f0071e81ad477135e3c1e270534dfe4be20c7f45e316e13d33c79944d282ed3223251122983a0f3199ea57c3431a24c1d
+DIST gspell-1.8.4.tar.xz 424356 BLAKE2B 031787c4f5c3f3cfe21d5f74ec72117818da43313c5e6dffb79581ca07033aede2ecf236ffdf2197938d62727c5bd3913d1362e02be7109b0d498304949e1d44 SHA512 adb481590442d81040151746c7747791d76248b1b35af1702dc5389efbd2e0c6bdda070b8e84384d22f4922b5a382ac2c6519e425f417ec85c8efbe22dc38c82
diff --git a/app-text/gspell/gspell-1.8.4.ebuild b/app-text/gspell/gspell-1.8.4.ebuild
new file mode 100644
index 000000000000..70eb544cba3a
--- /dev/null
+++ b/app-text/gspell/gspell-1.8.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-2.1.3:2
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? ( app-text/enchant:2[hunspell]
+ || ( app-dicts/myspell-en[l10n_en(+)] app-dicts/myspell-en[l10n_en-US(+)] ) )
+"
+# Tests require a en_US dictionary and fail with deprecated enchant aspell backend:
+# So enchant[hunspell] + myspell-en ensure they pass (hunspell is ordered before aspell),
+# however a different backend like hspell or nuspell + their en_US dict might be fine too,
+# but we don't support them at this time (2020-04-12) in enchant:2
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}