summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-06-14 08:43:32 -0300
committerMatt Turner <mattst88@gentoo.org>2023-06-14 11:46:04 -0400
commit778ba3074f80b380598ef59648358127f705e258 (patch)
treecfcbe162ccf8e4ecedcf887df19850e9769f0910 /app-text/libgepub
parentnet-p2p/cpuminer-opt: drop 3.22.1 (diff)
downloadgentoo-778ba3074f80b380598ef59648358127f705e258.tar.gz
gentoo-778ba3074f80b380598ef59648358127f705e258.tar.bz2
gentoo-778ba3074f80b380598ef59648358127f705e258.zip
app-text/libgepub: Version bump to 0.7.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31434 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text/libgepub')
-rw-r--r--app-text/libgepub/Manifest1
-rw-r--r--app-text/libgepub/libgepub-0.7.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-text/libgepub/Manifest b/app-text/libgepub/Manifest
index 78a6730119c1..9f1e7f85fc7f 100644
--- a/app-text/libgepub/Manifest
+++ b/app-text/libgepub/Manifest
@@ -1 +1,2 @@
DIST libgepub-0.7.0.tar.xz 28536 BLAKE2B beeab3d3911353cb0cac78207cc9e18e3341afce94213757c8d246a2d01c42aa0eb37618cc066307ce2ec8f21dbb89982271f25a9552d6872d5e86a4345407c6 SHA512 2ab661a6379899ff818313205d818ef1239654afde9ebcc22fa55b5d961aee20dd9c8295a58ff1d1fb1ea281ddb6ee8644942a860b3ee9f6a4ba9d7447efc517
+DIST libgepub-0.7.1.tar.xz 28576 BLAKE2B a65ecdd13bfcc96fbf0e1998d24cc565f0bd60213f278fdf592dcdf1ad6a1b40c9c10e3ffc3fe9ac500d92f5471619432badd746dfc57538e96a2b6a138b0a26 SHA512 9a9c56cffab485b78f0fdf115e655c4f395ee6e3f00b203fee5dfbb2054aa58540ca1fe8dc9dd82460ae3b39e89471e128086be10e77b247d0ce7b195bfbe8e3
diff --git a/app-text/libgepub/libgepub-0.7.1.ebuild b/app-text/libgepub/libgepub-0.7.1.ebuild
new file mode 100644
index 000000000000..d45480fd9b7b
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgepub"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection webkit"
+
+RDEPEND="
+ net-libs/libsoup:3.0
+ dev-libs/glib:2
+ dev-libs/libxml2
+ app-arch/libarchive:=
+ webkit? ( >=net-libs/webkit-gtk-2.38.0:4.1[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Tests are not executed by `meson test` and they require GTK+3
+ sed -i -e "/subdir('tests')/d" meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use webkit widget)
+ )
+ meson_src_configure
+}