summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/mecab
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/Manifest1
-rw-r--r--app-text/mecab/files/mecab-0.98-iconv.patch10
-rw-r--r--app-text/mecab/mecab-0.996.ebuild47
-rw-r--r--app-text/mecab/metadata.xml8
4 files changed, 66 insertions, 0 deletions
diff --git a/app-text/mecab/Manifest b/app-text/mecab/Manifest
new file mode 100644
index 000000000000..83dbfd2de109
--- /dev/null
+++ b/app-text/mecab/Manifest
@@ -0,0 +1 @@
+DIST mecab-0.996.tar.gz 1398663 SHA256 e073325783135b72e666145c781bb48fada583d5224fb2490fb6c1403ba69c59 SHA512 aca6d16f411b9ba9b6687242246aeb28ede6d6c6a9122d4a32da9d8e76e79b5f4af2c8e3b13ad9462b34e9d2994cbd9bbbedebac45609684db9b703da999577f WHIRLPOOL a21bcc48f61c98a20c299ccbe7ae1c1c39c5502903107906be7c5dfb6fafb60d0768a665cd3005339cd5fa4ff476bfdba53abbdbf114a7e8ccce9835de9b11cb
diff --git a/app-text/mecab/files/mecab-0.98-iconv.patch b/app-text/mecab/files/mecab-0.98-iconv.patch
new file mode 100644
index 000000000000..76ead6c38f99
--- /dev/null
+++ b/app-text/mecab/files/mecab-0.98-iconv.patch
@@ -0,0 +1,10 @@
+--- mecab-0.98/src/Makefile.am.old 2010-05-02 12:39:07.000000000 +0200
++++ mecab-0.98/src/Makefile.am 2010-05-02 12:39:28.000000000 +0200
+@@ -17,6 +17,7 @@
+ feature_index.cpp feature_index.h lbfgs.cpp \
+ lbfgs.h learner_tagger.cpp learner_tagger.h learner.cpp \
+ learner_node.h libmecab.cpp
++libmecab_la_LIBADD = $(LTLIBICONV)
+
+ include_HEADERS = mecab.h
+ bin_PROGRAMS = mecab
diff --git a/app-text/mecab/mecab-0.996.ebuild b/app-text/mecab/mecab-0.996.ebuild
new file mode 100644
index 000000000000..aa2307e527b5
--- /dev/null
+++ b/app-text/mecab/mecab-0.996.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="http://mecab.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+SLOT="0"
+IUSE="static-libs unicode"
+
+DEPEND="dev-lang/perl
+ virtual/libiconv"
+RDEPEND=""
+PDEPEND="|| (
+ app-dicts/mecab-ipadic[unicode=]
+ app-dicts/mecab-naist-jdic[unicode=]
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+ epatch "${FILESDIR}/${PN}-0.98-iconv.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with unicode charset UTF-8)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS README
+ dohtml -r doc/*
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/app-text/mecab/metadata.xml b/app-text/mecab/metadata.xml
new file mode 100644
index 000000000000..1ec95998be06
--- /dev/null
+++ b/app-text/mecab/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <upstream>
+ <remote-id type="google-code">mecab</remote-id>
+ </upstream>
+</pkgmetadata>