summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/xml2doc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/xml2doc')
-rw-r--r--app-text/xml2doc/Manifest1
-rw-r--r--app-text/xml2doc/files/xml2doc-pointer_fix.patch20
-rw-r--r--app-text/xml2doc/metadata.xml10
-rw-r--r--app-text/xml2doc/xml2doc-20030510-r1.ebuild60
4 files changed, 91 insertions, 0 deletions
diff --git a/app-text/xml2doc/Manifest b/app-text/xml2doc/Manifest
new file mode 100644
index 000000000000..87d0495f3976
--- /dev/null
+++ b/app-text/xml2doc/Manifest
@@ -0,0 +1 @@
+DIST xml2doc-20030510.tgz 53307 SHA256 dd675754a856f5ca40dfd12e0264ea51228c3d795f853d2310677fd25ea7866e SHA512 9eb2970b7adef1669b9b0aede2b3d2b42ba234c8294f0f8e6e230d8fcc6cf878675b2f0bff87ee36a255ab29376be844d92d382be7aad0ab11972847cfe49dbd WHIRLPOOL 86498838395687896a381dd63897c24cd968f53f16865ef26cde5dcecd63b3a8249bb45ffe65dabd4e18b41a704b22df0d13bcf3862b01ac50dc631a26c7794c
diff --git a/app-text/xml2doc/files/xml2doc-pointer_fix.patch b/app-text/xml2doc/files/xml2doc-pointer_fix.patch
new file mode 100644
index 000000000000..b6adabe3c1a3
--- /dev/null
+++ b/app-text/xml2doc/files/xml2doc-pointer_fix.patch
@@ -0,0 +1,20 @@
+diff -NurdpB xml2doc/src/output_info.c xml2doc-patched/src/output_info.c
+--- xml2doc/src/output_info.c 2003-04-25 05:11:27.000000000 -0500
++++ xml2doc-patched/src/output_info.c 2007-03-14 15:07:59.000000000 -0500
+@@ -9,11 +9,11 @@ void output_info()
+ *subject = xmlGetProp(Doc[n].cur,"subject"),
+ *keywords = xmlGetProp(Doc[n].cur,"keywords"),
+ *trapped = xmlGetProp(Doc[n].cur,"trapped");
+- struct time_t *timet;
+- struct tm *clk;
+-
+- time((time_t *)&timet);
+- clk=localtime((const time_t *)&timet);
++ time_t timet;
++ struct tm *clk;
++
++ time(&timet);
++ clk=localtime(&timet);
+
+ switch(DocS.output)
+ {
diff --git a/app-text/xml2doc/metadata.xml b/app-text/xml2doc/metadata.xml
new file mode 100644
index 000000000000..c24d382f30fa
--- /dev/null
+++ b/app-text/xml2doc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">xml2doc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/xml2doc/xml2doc-20030510-r1.ebuild b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
new file mode 100644
index 000000000000..6bc0ab191413
--- /dev/null
+++ b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to convert simple XML to a variety of formats (pdf, html, txt, manpage)"
+
+HOMEPAGE="http://xml2doc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ppc64 sparc x86"
+
+DEPEND=">=dev-libs/libxml2-2.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # Fix pointer-related bug detected by a QA notice.
+ epatch "${FILESDIR}/${PN}-pointer_fix.patch"
+
+ # Don't strip symbols from binary (bug #152266)
+ sed -i -e '/^\s*strip/d' \
+ -e 's/^\t$(CC) $(LFLAGS).*/\t$(LINK.o) $(L_PDF) $^ -lxml2 -o $(BIN)/' \
+ -e '/^\t$(CC) $(CFLAGS) /d' \
+ src/Makefile.in
+}
+
+src_configure() {
+ econf --disable-pdf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+
+ cd "${S}/doc"
+ "${S}"/src/xml2doc -oM manpage.xml xml2doc.1 || die
+}
+
+src_install() {
+ # xml2doc's make install is unfortunately broken
+
+ # binary
+ dobin src/xml2doc || die
+
+ # documentation
+ dodoc BUGS README TODO || die
+ docinto examples
+ dodoc examples/*.{xml,png} || die
+
+ # manpage
+ doman doc/xml2doc.1 || die
+}