summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 18:33:14 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 20:16:02 +0100
commita64edc83fe2ad2c085aa55f608afbe0077bc12b4 (patch)
treedaeab54bbd00d5efcdc7febfaff347a7247dc41b /app-text/zathura-cb
parentapp-text/zathura: [QA] Port to git-r3 (diff)
downloadgentoo-a64edc83fe2ad2c085aa55f608afbe0077bc12b4.tar.gz
gentoo-a64edc83fe2ad2c085aa55f608afbe0077bc12b4.tar.bz2
gentoo-a64edc83fe2ad2c085aa55f608afbe0077bc12b4.zip
app-text/zathura-cb: [QA] Port to git-r3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/zathura-cb')
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.2.ebuild24
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.6.ebuild28
-rw-r--r--app-text/zathura-cb/zathura-cb-9999.ebuild30
3 files changed, 39 insertions, 43 deletions
diff --git a/app-text/zathura-cb/zathura-cb-0.1.2.ebuild b/app-text/zathura-cb/zathura-cb-0.1.2.ebuild
index 82427371fee7..c9d8877d490c 100644
--- a/app-text/zathura-cb/zathura-cb-0.1.2.ebuild
+++ b/app-text/zathura-cb/zathura-cb-0.1.2.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="amd64 ~arm x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="git://git.pwmt.org/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="amd64 ~arm x86"
-else
-KEYWORDS=""
-fi
IUSE=""
COMMON_DEPEND=">=app-text/zathura-0.2.7
@@ -35,7 +33,7 @@ RDEPEND="${COMMON_DEPEND}
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
diff --git a/app-text/zathura-cb/zathura-cb-0.1.6.ebuild b/app-text/zathura-cb/zathura-cb-0.1.6.ebuild
index f7465379776a..ff2cb89529c1 100644
--- a/app-text/zathura-cb/zathura-cb-0.1.6.ebuild
+++ b/app-text/zathura-cb/zathura-cb-0.1.6.ebuild
@@ -4,21 +4,21 @@
EAPI=5
inherit eutils toolchain-funcs readme.gentoo-r1
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="amd64 arm x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="amd64 arm x86"
-fi
IUSE=""
RDEPEND=">=app-text/zathura-0.3.1
@@ -29,7 +29,7 @@ RDEPEND=">=app-text/zathura-0.3.1
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
@@ -45,13 +45,13 @@ src_compile() {
src_install() {
emake "${myzathuraconf[@]}" install
dodoc AUTHORS
+
+ FORCE_PRINT_ELOG=1
+ local DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
+ app-arch/unzip for additional file support."
readme.gentoo_create_doc
}
pkg_postinst() {
readme.gentoo_print_elog
}
-
-FORCE_PRINT_ELOG=1
-DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
-app-arch/unzip for additional file support."
diff --git a/app-text/zathura-cb/zathura-cb-9999.ebuild b/app-text/zathura-cb/zathura-cb-9999.ebuild
index 227a2188c278..32698cdd593e 100644
--- a/app-text/zathura-cb/zathura-cb-9999.ebuild
+++ b/app-text/zathura-cb/zathura-cb-9999.ebuild
@@ -4,23 +4,21 @@
EAPI=5
inherit eutils toolchain-funcs readme.gentoo-r1
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="~amd64 ~arm ~x86"
-else
-KEYWORDS=""
-fi
IUSE=""
RDEPEND=">=app-text/zathura-0.3.1
@@ -31,7 +29,7 @@ RDEPEND=">=app-text/zathura-0.3.1
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"
@@ -47,13 +45,13 @@ src_compile() {
src_install() {
emake "${myzathuraconf[@]}" install
dodoc AUTHORS
+
+ FORCE_PRINT_ELOG=1
+ local DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
+ app-arch/unzip for additional file support."
readme.gentoo_create_doc
}
pkg_postinst() {
readme.gentoo_print_elog
}
-
-FORCE_PRINT_ELOG=1
-DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
-app-arch/unzip for additional file support."