summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-29 00:50:26 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-29 00:50:45 +0200
commit1d13714f2a66bb0eb4ea88b33dc2404f6d4120df (patch)
treeb30600f6f892a94d7b964a7fd632b92dde1d984d /app-text
parentsci-libs/tensorflow: bump 2.4.0_rc3 (diff)
downloadgentoo-1d13714f2a66bb0eb4ea88b33dc2404f6d4120df.tar.gz
gentoo-1d13714f2a66bb0eb4ea88b33dc2404f6d4120df.tar.bz2
gentoo-1d13714f2a66bb0eb4ea88b33dc2404f6d4120df.zip
app-text/calibre: Fix build with icu-68
Closes: https://bugs.gentoo.org/752015 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/calibre-4.22.0.ebuild3
-rw-r--r--app-text/calibre/calibre-4.23.0.ebuild3
-rw-r--r--app-text/calibre/calibre-5.4.2.ebuild1
-rw-r--r--app-text/calibre/files/calibre-4.22.0-icu68.patch37
4 files changed, 42 insertions, 2 deletions
diff --git a/app-text/calibre/calibre-4.22.0.ebuild b/app-text/calibre/calibre-4.22.0.ebuild
index 7dca7d16c3d3..317dde693999 100644
--- a/app-text/calibre/calibre-4.22.0.ebuild
+++ b/app-text/calibre/calibre-4.22.0.ebuild
@@ -122,7 +122,8 @@ src_prepare() {
# disable_plugins: walking sec-hole, wait for upstream to use GHNS interface
eapply \
"${FILESDIR}/${PN}-2.9.0-no_updates_dialog.patch" \
- "${FILESDIR}/${PN}-disable_plugins.patch"
+ "${FILESDIR}/${PN}-disable_plugins.patch" \
+ "${FILESDIR}/${PN}-4.22.0-icu68.patch"
eapply_user
diff --git a/app-text/calibre/calibre-4.23.0.ebuild b/app-text/calibre/calibre-4.23.0.ebuild
index 2e529363d2c8..fffb7f953b4e 100644
--- a/app-text/calibre/calibre-4.23.0.ebuild
+++ b/app-text/calibre/calibre-4.23.0.ebuild
@@ -122,7 +122,8 @@ src_prepare() {
# disable_plugins: walking sec-hole, wait for upstream to use GHNS interface
eapply \
"${FILESDIR}/${PN}-2.9.0-no_updates_dialog.patch" \
- "${FILESDIR}/${PN}-disable_plugins.patch"
+ "${FILESDIR}/${PN}-disable_plugins.patch" \
+ "${FILESDIR}/${PN}-4.22.0-icu68.patch"
eapply_user
diff --git a/app-text/calibre/calibre-5.4.2.ebuild b/app-text/calibre/calibre-5.4.2.ebuild
index 6c46bbdb0639..ca89fb15aef0 100644
--- a/app-text/calibre/calibre-5.4.2.ebuild
+++ b/app-text/calibre/calibre-5.4.2.ebuild
@@ -124,6 +124,7 @@ src_prepare() {
eapply \
"${FILESDIR}/${PN}-2.9.0-no_updates_dialog.patch" \
"${FILESDIR}/${PN}-disable_plugins.patch" \
+ "${FILESDIR}/${PN}-4.22.0-icu68.patch" \
"${WORKDIR}/${PN}-5.4.2-SIP-v4.patch"
eapply_user
diff --git a/app-text/calibre/files/calibre-4.22.0-icu68.patch b/app-text/calibre/files/calibre-4.22.0-icu68.patch
new file mode 100644
index 000000000000..33cd7830d358
--- /dev/null
+++ b/app-text/calibre/files/calibre-4.22.0-icu68.patch
@@ -0,0 +1,37 @@
+From c211f9b17af410463ce9cfc9b1b100228b51720f Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Sat, 31 Oct 2020 10:44:36 +0100
+Subject: [PATCH] Fix build with icu-68.1
+
+icu-68.1 removed public macro definitions for TRUE and FALSE
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ src/calibre/utils/icu.c | 4 ++--
+ src/calibre/utils/matcher.c | 1 -
+ 2 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/src/calibre/utils/icu.c b/src/calibre/utils/icu.c
+index 62d05de310..4e918492d9 100644
+--- a/src/calibre/utils/icu.c
++++ b/src/calibre/utils/icu.c
+@@ -238,14 +238,14 @@ icu_Collator_contains(icu_Collator *self, PyObject *args) {
+
+ a = python_to_icu(a_, &asz);
+ if (a == NULL) goto end;
+- if (asz == 0) { found = TRUE; goto end; }
++ if (asz == 0) { found = 1; goto end; }
+ b = python_to_icu(b_, &bsz);
+ if (b == NULL) goto end;
+
+ search = usearch_openFromCollator(a, asz, b, bsz, self->collator, NULL, &status);
+ if (U_SUCCESS(status)) {
+ pos = usearch_first(search, &status);
+- if (pos != USEARCH_DONE) found = TRUE;
++ if (pos != USEARCH_DONE) found = 1;
+ }
+ end:
+ if (search != NULL) usearch_close(search);
+--
+2.29.2
+