summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-11 20:51:48 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-02-11 20:52:12 +0100
commita9d34704b8f19365fb585cec6b71dd2b344e8316 (patch)
treedd7e7edbee6aa67a3883cc8b214c3d69617b9654 /app-text
parentmedia-radio/xastir: Use sub-slot operators for imagemagick (diff)
downloadgentoo-a9d34704b8f19365fb585cec6b71dd2b344e8316.tar.gz
gentoo-a9d34704b8f19365fb585cec6b71dd2b344e8316.tar.bz2
gentoo-a9d34704b8f19365fb585cec6b71dd2b344e8316.zip
app-text/enscript: Honor AR setting, bug 447620
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enscript/enscript-1.6.6.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6.ebuild
index 25066b19d186..4246f7c5312f 100644
--- a/app-text/enscript/enscript-1.6.6.ebuild
+++ b/app-text/enscript/enscript-1.6.6.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="2"
+EAPI=6
-inherit eutils
+inherit eutils toolchain-funcs
-DESCRIPTION="powerful text-to-postscript converter"
+DESCRIPTION="Powerful text-to-postscript converter"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
HOMEPAGE="https://www.gnu.org/software/enscript/enscript.html"
@@ -27,26 +27,27 @@ src_prepare() {
epatch "${FILESDIR}"/enscript-1.6.5.2-php.st.patch
use ruby && epatch "${FILESDIR}"/enscript-1.6.2-ruby.patch
sed -i src/tests/passthrough.test -e 's|tail +2|tail -n +2|g' || die
+ default
}
src_configure() {
econf $(use_enable nls)
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README* THANKS TODO || die "dodoc failed"
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
insinto /usr/share/enscript/hl
- doins "${FILESDIR}"/ebuild.st || die "doins ebuild.st failed"
+ doins "${FILESDIR}"/ebuild.st
if use ruby ; then
insinto /usr/share/enscript/hl
- doins "${FILESDIR}"/ruby.st || die "doins ruby.st failed"
+ doins "${FILESDIR}"/ruby.st
fi
}
-
-pkg_postinst() {
- elog "Now, customize /etc/enscript.cfg."
-}