summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-12 16:19:02 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:31 +0200
commit6d2f09aeb42163628bba02a8bbfc4c847b63a1d2 (patch)
tree470304484ba75c2e94ef06b0ef04de24a91e55a5 /app-vim/cctree
parentapp-vim/calendar: EAPI8 bump (diff)
downloadgentoo-6d2f09aeb42163628bba02a8bbfc4c847b63a1d2.tar.gz
gentoo-6d2f09aeb42163628bba02a8bbfc4c847b63a1d2.tar.bz2
gentoo-6d2f09aeb42163628bba02a8bbfc4c847b63a1d2.zip
app-vim/cctree: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/cctree')
-rw-r--r--app-vim/cctree/cctree-1.61-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/cctree/cctree-1.61-r2.ebuild b/app-vim/cctree/cctree-1.61-r2.ebuild
new file mode 100644
index 000000000000..5f3cc27fb666
--- /dev/null
+++ b/app-vim/cctree/cctree-1.61-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
+HOMEPAGE="https://sites.google.com/site/vimcctree/"
+
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-util/cscope"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc || die
+ sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
+ ftplugin/${PN}.vim > doc/${PN}.txt || die
+
+ default
+}