summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 16:52:51 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:36 +0200
commit99bf7b791e6cbf027bf89fd80b49f493f3e15a5e (patch)
tree73a86be183426d91ea25332c174d1f0cef37ce1f /app-vim/fluxbox-syntax
parentapp-vim/eselect-syntax: EAPI8 bump (diff)
downloadgentoo-99bf7b791e6cbf027bf89fd80b49f493f3e15a5e.tar.gz
gentoo-99bf7b791e6cbf027bf89fd80b49f493f3e15a5e.tar.bz2
gentoo-99bf7b791e6cbf027bf89fd80b49f493f3e15a5e.zip
app-vim/fluxbox-syntax: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/fluxbox-syntax')
-rw-r--r--app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild
new file mode 100644
index 000000000000..28e337173b22
--- /dev/null
+++ b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fluxbox files syntax and indent"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=679"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-vim/genindent"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting and indent settings for fluxbox
+menus and similar files. Upstream don't provide us with an ftdetect file,
+but a simple one has been created for you by this ebuild. You can manually
+set the filetype using :set filetype=fluxbox if necessary."
+
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ mkdir ftdetect || die
+ echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
+ > ftdetect/fluxbox.vim || die
+}