summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-12 19:58:25 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-12 19:58:56 -0700
commita08e6eca21713e61e788872d75545fdb6a881097 (patch)
tree44dfea9322b30474c607425e1b2e138f8cdca719 /app-vim/fugitive
parentdev-java/gwt: Patch (by me) to not run git (diff)
downloadgentoo-a08e6eca21713e61e788872d75545fdb6a881097.tar.gz
gentoo-a08e6eca21713e61e788872d75545fdb6a881097.tar.bz2
gentoo-a08e6eca21713e61e788872d75545fdb6a881097.zip
app-vim/fugitive: version bump to 3.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim/fugitive')
-rw-r--r--app-vim/fugitive/Manifest1
-rw-r--r--app-vim/fugitive/fugitive-3.1.ebuild22
-rw-r--r--app-vim/fugitive/fugitive-9999.ebuild2
3 files changed, 24 insertions, 1 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index f85c196ebc2b..f3c44f0541a9 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -1,2 +1,3 @@
DIST fugitive-2.4.tar.gz 33340 BLAKE2B d5e5df47e0492510abae735dd47b51d797fe38862401f7d8e64404f6fa4e040641141c6febb13b05910cc44dc0372b084fe0ee8c3980a73d11d65e1a502ed627 SHA512 fb9d4129090bbafcace9400e9f21feae06bc9f903a54cfef7c4cbfa62856019a511b924c294e86fd26cd713d588ca0054a17d9676b59e2f406779ab5d51c3363
DIST fugitive-2.5.tar.gz 39318 BLAKE2B 437f4c36b357937fc83e0107882d535c5cc9e609801147d1a48c28e16c4f964c221ff404301e57c9d740a04caf4cf5383a1f307ad89a76294e13b784561223bd SHA512 9a58ff3fa9eae72fca3d1232d01856ef56fe38b7bbf61be44ec4cdf4f0f69fca69fafe19266d657530a6d08f856236b1d1370bb770b14402bb7e476d5ca4bb78
+DIST fugitive-3.1.tar.gz 61142 BLAKE2B 15436725924d7ab09903973d77e9d7ce904f6bfaee451da2d3240236b2ef0589efd4b34e3673550749a6f021802018b2fb86f09ecdd727231f58bce3fd7c82b0 SHA512 4301e53a688ef1c822c146e04c41b6724cc38503733c622c0be8ea67ff2dd442f487fab8569bd3c8f7d97f6a4d5b42b58c0f23a216d74b862c09ed5c57f6ea87
diff --git a/app-vim/fugitive/fugitive-3.1.ebuild b/app-vim/fugitive/fugitive-3.1.ebuild
new file mode 100644
index 000000000000..0d4da8993529
--- /dev/null
+++ b/app-vim/fugitive/fugitive-3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"
diff --git a/app-vim/fugitive/fugitive-9999.ebuild b/app-vim/fugitive/fugitive-9999.ebuild
index fe8da7842fc2..0d4da8993529 100644
--- a/app-vim/fugitive/fugitive-9999.ebuild
+++ b/app-vim/fugitive/fugitive-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7