summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2024-09-05 16:27:56 +0200
committerAlexis Ballier <aballier@gentoo.org>2024-09-08 11:47:28 +0200
commitbef87c89d5e3ff3c7f321512cc4dbc9def5cae17 (patch)
tree9f68f4a8fdd86d68eeedef0ee695bc9e16032d47 /dev-build/ignition-cmake
parentmedia-video/wireplumber: add 0.5.6 (diff)
downloadgentoo-bef87c89d5e3ff3c7f321512cc4dbc9def5cae17.tar.gz
gentoo-bef87c89d5e3ff3c7f321512cc4dbc9def5cae17.tar.bz2
gentoo-bef87c89d5e3ff3c7f321512cc4dbc9def5cae17.zip
dev-build/ignition-cmake: remove patch causing issues with recent protobufs
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-build/ignition-cmake')
-rw-r--r--dev-build/ignition-cmake/ignition-cmake-2.17.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-build/ignition-cmake/ignition-cmake-2.17.2-r1.ebuild b/dev-build/ignition-cmake/ignition-cmake-2.17.2-r1.ebuild
new file mode 100644
index 000000000000..7eefbd534ef4
--- /dev/null
+++ b/dev-build/ignition-cmake/ignition-cmake-2.17.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CMake modules to be used by the Ignition projects"
+HOMEPAGE="https://github.com/ignitionrobotics/ign-cmake"
+SRC_URI="https://github.com/gazebosim/gz-cmake/archive/refs/tags/${PN}2_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+S="${WORKDIR}/gz-cmake-${PN}2_${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_TESTING=$(usex test)"
+ )
+ cmake_src_configure
+}