summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2023-09-04 12:08:05 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-04 12:08:05 +0200
commit72af436c1c0914a435f8954124d45dcafd001418 (patch)
tree8da6c987d43c3459abdae2c91181b546a127d564 /dev-cpp/gtest
parentx11-misc/birdtray: remove old 1.11.x series (diff)
downloadgentoo-72af436c1c0914a435f8954124d45dcafd001418.tar.gz
gentoo-72af436c1c0914a435f8954124d45dcafd001418.tar.bz2
gentoo-72af436c1c0914a435f8954124d45dcafd001418.zip
dev-cpp/gtest: pass -DPython3_EXECUTABLE only if USE=test
Switch -DPYTHON_EXECUTABLE to the more modern CMAKE -DPython3_EXECUTABLE. And consistent with other conditional constructs, eg. "use test && python-any-r1_pkg_setup", only pass -DPython3_EXECUTABLE if USE=test. Closes: https://bugs.gentoo.org/911476 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/gtest')
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 1e958926faa8..d46c8086a02a 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -53,8 +53,9 @@ multilib_src_configure() {
# tests
-Dgmock_build_tests=$(usex test)
-Dgtest_build_tests=$(usex test)
- -DPYTHON_EXECUTABLE="${PYTHON}"
)
+ use test && mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
+
cmake_src_configure
}