summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-02-06 23:22:35 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-22 18:06:07 +0100
commit9527828aa0d2513706c55063a2d04eb783d6a808 (patch)
treeb80e3a03f0800c4a129ae72b807eff2a86491137 /dev-cpp/libcmis/files
parentmedia-libs/libcdr: Fix build with boost-1.59 (bug 574120) (diff)
downloadgentoo-9527828aa0d2513706c55063a2d04eb783d6a808.tar.gz
gentoo-9527828aa0d2513706c55063a2d04eb783d6a808.tar.bz2
gentoo-9527828aa0d2513706c55063a2d04eb783d6a808.zip
dev-cpp/libcmis: Add upstream patches to fix bugs 556914, 569614
All tests passed. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-cpp/libcmis/files')
-rw-r--r--dev-cpp/libcmis/files/libcmis-0.5.0-boost-linking.patch21
-rw-r--r--dev-cpp/libcmis/files/libcmis-0.5.0-cppcheck.patch44
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-cpp/libcmis/files/libcmis-0.5.0-boost-linking.patch b/dev-cpp/libcmis/files/libcmis-0.5.0-boost-linking.patch
new file mode 100644
index 000000000000..348a590f4c30
--- /dev/null
+++ b/dev-cpp/libcmis/files/libcmis-0.5.0-boost-linking.patch
@@ -0,0 +1,21 @@
+From b572b60a5fdc630f7f3b31dfd5dbdd1ed48659ca Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?C=C3=A9dric=20Bosdonnat?= <cedric.bosdonnat@free.fr>
+Date: Thu, 16 Jul 2015 16:22:11 +0200
+Subject: [PATCH] Fix linking error when building with --with-boot
+
+---
+ src/libcmis/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/libcmis/Makefile.am b/src/libcmis/Makefile.am
+index 3915d45..1955ea6 100644
+--- a/src/libcmis/Makefile.am
++++ b/src/libcmis/Makefile.am
+@@ -144,6 +144,7 @@ libcmis_@LIBCMIS_API_VERSION@_la_LIBADD = \
+ $(XML2_LIBS) \
+ $(CURL_LIBS) \
+ $(BOOST_SMART_PTR_LIBS) \
++ $(BOOST_DATE_TIME_LDFLAGS) \
+ $(BOOST_DATE_TIME_LIBS)
+
+ libcmis_@LIBCMIS_API_VERSION@_la_includedir = $(includedir)/libcmis-@LIBCMIS_API_VERSION@/libcmis
diff --git a/dev-cpp/libcmis/files/libcmis-0.5.0-cppcheck.patch b/dev-cpp/libcmis/files/libcmis-0.5.0-cppcheck.patch
new file mode 100644
index 000000000000..8c89ab8bfe33
--- /dev/null
+++ b/dev-cpp/libcmis/files/libcmis-0.5.0-cppcheck.patch
@@ -0,0 +1,44 @@
+From 0ad3ec084d918be503a8ce971af1b54887d7726f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?C=C3=A9dric=20Bosdonnat?= <cedric.bosdonnat@free.fr>
+Date: Thu, 16 Jul 2015 16:23:06 +0200
+Subject: [PATCH] Getting cppcheck-test to pass again
+
+---
+ Makefile.am | 1 +
+ cppcheck-suppress | 3 +++
+ cppcheck-test.sh.in | 4 +++-
+ 3 files changed, 7 insertions(+), 1 deletion(-)
+ create mode 100644 cppcheck-suppress
+
+diff --git a/Makefile.am b/Makefile.am
+index ebf1f3b..9263497 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -35,6 +35,7 @@ EXTRA_DIST = \
+ COPYING.LGPL \
+ doc/cmis-client.xml \
+ cppcheck-test.sh \
++ cppcheck-suppress \
+ qa/libcmis/data
+
+ if ENABLE_CPPCHECK
+diff --git a/cppcheck-suppress b/cppcheck-suppress
+new file mode 100644
+index 0000000..9ef8482
+--- /dev/null
++++ b/cppcheck-suppress
+@@ -0,0 +1,3 @@
++publicAllocationError:qa/libcmis/test-decoder.cxx
++noExplicitConstructor
++noExplicitCopyMoveConstructor
+diff --git a/cppcheck-test.sh.in b/cppcheck-test.sh.in
+index 20a73f8..175e0f5 100755
+--- a/cppcheck-test.sh.in
++++ b/cppcheck-test.sh.in
+@@ -1,3 +1,5 @@
+ #!/bin/sh
+-@CPPCHECK@ -q --enable=style,performance,portability,information --error-exitcode=1 @SRCDIR@
++@CPPCHECK@ -q --enable=style,performance,portability,information \
++ --suppressions-list=./cppcheck-suppress \
++ --error-exitcode=1 @SRCDIR@
+ exit $?