summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-08 20:17:08 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-08 20:33:57 +0200
commitcb0f83a370cfd200a8cdca6e782b4bb9f3ca4055 (patch)
tree2a6049d57c0a08a77e9aabd5df8dd4aff540bbb1 /dev-cpp/prometheus-cpp
parentprofiles/arch/mips: mask =dev-lang/rust-1.71.1 (diff)
downloadgentoo-cb0f83a370cfd200a8cdca6e782b4bb9f3ca4055.tar.gz
gentoo-cb0f83a370cfd200a8cdca6e782b4bb9f3ca4055.tar.bz2
gentoo-cb0f83a370cfd200a8cdca6e782b4bb9f3ca4055.zip
dev-cpp/prometheus-cpp: drop 1.1.0
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-cpp/prometheus-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest1
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index f0308f8c5d76..591bce8787fd 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1,2 +1 @@
-DIST prometheus-cpp-1.1.0.tar.gz 58489 BLAKE2B af24fbc34e79c04ec80dbf4430de5a2cf0e66b7de4c06f9b37e6bc3ab7f868b948db486a4f962c7986748eff1247eb0119ad5b581ac01129ce6bfa10f7b53ec7 SHA512 0715a0eb8a7f7065e01b8039c261eaa98a77a8d035783ccef9333fb06eecd75599959807ec157514c60ed435841bcd0cdd8cd295bcf7cd88e21e1099ba12be89
DIST prometheus-cpp-1.2.4.tar.gz 73953 BLAKE2B 75ca7b8c88408b54ab806dcc8ecaa48c9d29a7cbb76fe786fc76e114fa0bfcacaced7d899f8aff24060c9cbb4836d144b25fca2ac45438982789bcf881fade67 SHA512 8c15492054189b736e502258c30aaaae0fac3c9ea61907260e6e3cd29fe4077451f9e49fd580508aa6e21691209545d9cf87011be5b046fa097a53a133167553
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild
deleted file mode 100644
index 6239a46b04df..000000000000
--- a/dev-cpp/prometheus-cpp/prometheus-cpp-1.1.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Prometheus Client Library for Modern C++"
-HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
-SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="test zlib"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="net-misc/curl
- sys-libs/zlib
- www-servers/civetweb[cxx]"
-DEPEND="${RDEPEND}
- test? (
- dev-cpp/benchmark
- dev-cpp/gtest
- )"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_PULL=yes
- -DENABLE_PUSH=yes
- -DENABLE_COMPRESSION=$(usex zlib)
- -DENABLE_TESTING=$(usex test)
- -DUSE_THIRDPARTY_LIBRARIES=OFF
- -DGENERATE_PKGCONFIG=ON
- -DRUN_IWYU=OFF
- )
-
- cmake_src_configure
-}