summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-12 12:32:16 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-12 12:53:47 +0200
commite09d14eac5f94ff90cbdb5bdafac45324ade2c94 (patch)
treecf7c47bd8d5fad11e18c1e7f138bcb5c68c41e47 /dev-cpp/prometheus-cpp
parentdev-cpp/benchmark: drop 1.5.1, 1.5.2 (diff)
downloadgentoo-e09d14eac5f94ff90cbdb5bdafac45324ade2c94.tar.gz
gentoo-e09d14eac5f94ff90cbdb5bdafac45324ade2c94.tar.bz2
gentoo-e09d14eac5f94ff90cbdb5bdafac45324ade2c94.zip
dev-cpp/prometheus-cpp: add 0.12.3
Suggested-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://bugs.gentoo.org/789162 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-cpp/prometheus-cpp')
-rw-r--r--dev-cpp/prometheus-cpp/Manifest1
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-0.12.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index 3519a469256c..78b153008a1e 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1 +1,2 @@
DIST prometheus-cpp-0.12.2.tar.gz 55191 BLAKE2B f1430cf6b8ca8272c447e8c2a25af5fb0d515389cb1078f8836a9a1f1ba0e26cc43236e9c147219384df40d601b843219acb95ebc46bb1c2fce6d83a86724182 SHA512 9907658939b7956219c3623bd5997f341f4374fbce2ee606bd1d8df820779ed8dc70658a30aafbb47b9af645205c048270b23e701203e13286bc365094a441d3
+DIST prometheus-cpp-0.12.3.tar.gz 55510 BLAKE2B 8a9dffb4608f1d1f141726cf7bec3a19ca9040baca9871ff3aa950aa979b34319e704539ff3f2830a5c145645e9c3c0efc9e9b2c5c534d8b3745aaf1e9426763 SHA512 e8093db6e58d1672fd94daeed94f2c11f663145195bf878e0403973f2f4f62a3f9430cf6de1fc9ac0821b4b323e3faeb96199d450b3d7a04a5dee0e6f94ddc01
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.3.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.3.ebuild
new file mode 100644
index 000000000000..dca730a03e41
--- /dev/null
+++ b/dev-cpp/prometheus-cpp/prometheus-cpp-0.12.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Prometheus Client Library for Modern C++"
+HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
+SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="net-misc/curl
+ sys-libs/zlib
+ www-servers/civetweb[cxx]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/benchmark
+ dev-cpp/gtest
+ )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_PULL=yes
+ -DENABLE_PUSH=yes
+ -DENABLE_COMPRESSION=$(usex zlib)
+ -DENABLE_TESTING=$(usex test)
+ -DUSE_THIRDPARTY_LIBRARIES=OFF
+ -DGENERATE_PKGCONFIG=ON
+ -DRUN_IWYU=OFF
+ )
+
+ cmake_src_configure
+}