summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-05-17 22:17:24 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-05-17 22:25:38 -0500
commitc55d1e51403733ffcaf899f1da9110e8b118cf54 (patch)
tree2b439266ec0340cabf52b02f21095d0bb19066d3 /dev-cpp
parentdev-cpp/cpp-taskflow: update live ebuild (diff)
downloadgentoo-c55d1e51403733ffcaf899f1da9110e8b118cf54.tar.gz
gentoo-c55d1e51403733ffcaf899f1da9110e8b118cf54.tar.bz2
gentoo-c55d1e51403733ffcaf899f1da9110e8b118cf54.zip
dev-cpp/cpp-taskflow: drop 3.2.0
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpp-taskflow/Manifest1
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
index 61c03f9dcff0..d70f06ff30fb 100644
--- a/dev-cpp/cpp-taskflow/Manifest
+++ b/dev-cpp/cpp-taskflow/Manifest
@@ -1,2 +1 @@
-DIST cpp-taskflow-3.2.0.tar.gz 79152157 BLAKE2B 03b4b1cf772c9dec4557a706c7872de95312d4e72ec7dcef1accfd1d5eaf470e60440d75ea0c993ab494ef460dc44639719ea1732fa92c54d64dde31b90b9224 SHA512 e30d95b69f64524c9b06cf7442236998f91b1083818f06439888d78d5a1b988bc952c02fd0ec88114283cbe6c31a7bbfe810a7114998f4b5f60c4cff921bb0fa
DIST cpp-taskflow-3.3.0.tar.gz 64446007 BLAKE2B 07878a03bd90af64914f1dc80850bcf5d4140f20ecfa998237039b6f37cc668e8c2b5dffafb75f4518209b3ac01f9935f5e30a020871334f131e6fe7654748bf SHA512 08ab20bf38927d49c8332fc103cb7b4b6358efa06466cb8471f2004eb27b79b9eadc9971ec4acd110c8f369686b6f99bf3e21192285c3f28b9cb855bfd9ab0b5
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
deleted file mode 100644
index 9b146d9dc546..000000000000
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-3.2.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Modern C++ Parallel Task Programming"
-HOMEPAGE="https://cpp-taskflow.github.io"
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/cpp-taskflow/${PN}.git"
- inherit git-r3
- S="${WORKDIR}/cpp-taskflow-${PV}"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/taskflow-${PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-cpp/doctest )"
-
-HTML_DOCS=( docs/. )
-
-src_prepare() {
- rm -r "${S}/3rd-party" || die "rm failed"
- default
- cmake_src_prepare
-}
-
-src_configure() {
- # TODO: enable CUDA via USE flag
- local mycmakeargs=(
- -DTF_BUILD_CUDA=OFF
- -DTF_BUILD_EXAMPLES=$(usex examples)
- -DTF_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}