summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-09-08 15:59:49 +0200
committerAgostino Sarubbo <ago@gentoo.org>2021-09-08 15:59:49 +0200
commit2afee7cf96e4a568c1d96af5b6d52ab027f0017b (patch)
treecd58029661fdc6477de3d88684becffd83d28c4f /dev-db/pg_activity
parentlinux-info.eclass : Remove log references to linux 2.4 and gcc 4 (diff)
downloadgentoo-2afee7cf96e4a568c1d96af5b6d52ab027f0017b.tar.gz
gentoo-2afee7cf96e4a568c1d96af5b6d52ab027f0017b.tar.bz2
gentoo-2afee7cf96e4a568c1d96af5b6d52ab027f0017b.zip
dev-db/pg_activity: version bump t 2.2.1
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-db/pg_activity')
-rw-r--r--dev-db/pg_activity/Manifest1
-rw-r--r--dev-db/pg_activity/pg_activity-2.2.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-db/pg_activity/Manifest b/dev-db/pg_activity/Manifest
index 069c648ac6c9..9cc0e2b2f7dc 100644
--- a/dev-db/pg_activity/Manifest
+++ b/dev-db/pg_activity/Manifest
@@ -1 +1,2 @@
DIST pg_activity-2.1.5.tar.gz 277854 BLAKE2B 49dce244d553f516c5d52a061d36a7c51940566e9a13286d3913758eebdc4dbdfbeef9b6954f1c6f41a83647d255e50ea23c6597605571a4563b3cb02fdaec87 SHA512 78d6560ec15b435eeeeaa132851337f04822d42e4288425d85a78842f321ad2c426041cb953fabc8f3f406b9d68e4001a3df5ba2c9223bc0facc2a65619979e0
+DIST pg_activity-2.2.1.tar.gz 279973 BLAKE2B fda51751d2d6e83eac1f9a731c085b0f37258a5aaf38116f2a90008554d6c8ce48cc615ee9b9a34ab9631b315dba6a763f634754e36b7b5590e08e3077878bb7 SHA512 8128dab29465b1521801a0abdbe242c08ee33aba63b6a29b04293e83383a66a302d96a1980afdc5e92b44aebb784f5b093f48dd22e3d2e703247f4f3408120e5
diff --git a/dev-db/pg_activity/pg_activity-2.2.1.ebuild b/dev-db/pg_activity/pg_activity-2.2.1.ebuild
new file mode 100644
index 000000000000..76fc218aadab
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-2.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt and not test_data.py'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}