summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/soci
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/soci')
-rw-r--r--dev-db/soci/Manifest2
-rw-r--r--dev-db/soci/metadata.xml15
-rw-r--r--dev-db/soci/soci-3.2.2.ebuild47
-rw-r--r--dev-db/soci/soci-3.2.3.ebuild47
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-db/soci/Manifest b/dev-db/soci/Manifest
new file mode 100644
index 000000000000..831b525efbbb
--- /dev/null
+++ b/dev-db/soci/Manifest
@@ -0,0 +1,2 @@
+DIST soci-3.2.2.zip 518502 SHA256 e3ad3ea0ef37eab0ae9e6459d2cdd099b1fa1165b663c349e1200356cf4e9c91 SHA512 36fa977e8827ec546ec85be45d78bb21b2700ee7838d144e6f6ac91cc70242cbe8ce968092146e2b29d52fe1022b9287cff7465c156a49c0ffb1dde6d89964ab WHIRLPOOL e25bc0ec7ca1137db5b703635ea0066b8e93307e721c2e4efc45f0d008abff8c9b944b483dfd9c45a6361e7bd049f70570342ae4ea0e0594f9d0914268d00873
+DIST soci-3.2.3.zip 508929 SHA256 ab0f82873b0c5620e0e8eb2ff89abad6517571fd63bae4bdcac64dd767ac9a05 SHA512 dd9b7eaf535502e3230eada4d4d019963d2c9cf59b69fff5d466b4fc00976fa08f7b0199a0e4564a0395d0d30095b97aa1d613dfbaa329feb077ece3b0efacdf WHIRLPOOL ce4316de7228ba44a7440fe2e90c6252f5d5780b6826bd1b41cce7fe471551bb454d4658c3b07813050d36ec17886c6f583e1d531ee63c671d648bccfc63b1b1
diff --git a/dev-db/soci/metadata.xml b/dev-db/soci/metadata.xml
new file mode 100644
index 000000000000..bef37b683d33
--- /dev/null
+++ b/dev-db/soci/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+ <use>
+ <flag name="boost">Enable boost support</flag>
+ <flag name="empty">Build the sample backend called Empty</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">soci</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/soci/soci-3.2.2.ebuild b/dev-db/soci/soci-3.2.2.ebuild
new file mode 100644
index 000000000000..818391b5c1b4
--- /dev/null
+++ b/dev-db/soci/soci-3.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A db access library for C++ that makes the illusion of embedding SQL queries in the regular C++ code"
+HOMEPAGE="http://soci.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="boost doc +empty firebird mysql odbc oracle postgres sqlite"
+
+DEPEND="boost? ( dev-libs/boost )
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use_with boost )
+ $(cmake-utils_use empty SOCI_EMPTY)
+ $(cmake-utils_use_with firebird FIREBIRD)
+ $(cmake-utils_use_with mysql MYSQL)
+ $(cmake-utils_use_with odbc ODBC)
+ $(cmake-utils_use_with oracle ORACLE)
+ $(cmake-utils_use_with postgres POSTGRESQL)
+ $(cmake-utils_use_with sqlite SQLITE3)
+ -DWITH_DB2=OFF" #use MYCMAKEARGS if you want enable IBM DB2 support
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS CHANGES
+ if use doc; then
+ dohtml -r doc/*
+ fi
+}
diff --git a/dev-db/soci/soci-3.2.3.ebuild b/dev-db/soci/soci-3.2.3.ebuild
new file mode 100644
index 000000000000..818391b5c1b4
--- /dev/null
+++ b/dev-db/soci/soci-3.2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A db access library for C++ that makes the illusion of embedding SQL queries in the regular C++ code"
+HOMEPAGE="http://soci.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="boost doc +empty firebird mysql odbc oracle postgres sqlite"
+
+DEPEND="boost? ( dev-libs/boost )
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ oracle? ( dev-db/oracle-instantclient-basic )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use_with boost )
+ $(cmake-utils_use empty SOCI_EMPTY)
+ $(cmake-utils_use_with firebird FIREBIRD)
+ $(cmake-utils_use_with mysql MYSQL)
+ $(cmake-utils_use_with odbc ODBC)
+ $(cmake-utils_use_with oracle ORACLE)
+ $(cmake-utils_use_with postgres POSTGRESQL)
+ $(cmake-utils_use_with sqlite SQLITE3)
+ -DWITH_DB2=OFF" #use MYCMAKEARGS if you want enable IBM DB2 support
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS CHANGES
+ if use doc; then
+ dohtml -r doc/*
+ fi
+}