summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-07 18:24:33 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-14 18:07:19 +0100
commita22d9c8252281c317f85d0af45cdff10f546821f (patch)
tree58709a102add73ec32161cb6e45bca0a808c7c93 /dev-dotnet
parenteclass/dotnet-pkg-base.eclass: add DOTNET_VERBOSITY user variable (diff)
downloadgentoo-a22d9c8252281c317f85d0af45cdff10f546821f.tar.gz
gentoo-a22d9c8252281c317f85d0af45cdff10f546821f.tar.bz2
gentoo-a22d9c8252281c317f85d0af45cdff10f546821f.zip
dev-dotnet/dotnet-sdk: use DOTNET_VERBOSITY, like the dotnet-pkg-base eclass
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.107-r2.ebuild6
-rw-r--r--dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.101.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.107-r2.ebuild b/dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.107-r2.ebuild
index e275af4d57a6..6cb26506cedd 100644
--- a/dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.107-r2.ebuild
+++ b/dev-dotnet/dotnet-sdk/dotnet-sdk-8.0.107-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Pre-build (and distribution preparation)
@@ -15,7 +15,7 @@
# Build ("src_compile")
# To learn about arguments that are passed to the "build.sh" script see:
# https://github.com/dotnet/source-build/discussions/4082
-# User variable: GENTOO_DOTNET_BUILD_VERBOSITY - set other verbosity log level.
+# User variable: DOTNET_VERBOSITY - set other verbosity log level.
EAPI=8
@@ -199,7 +199,7 @@ src_compile() {
# The "source_repository" should always be the same.
local source_repository="https://github.com/dotnet/dotnet"
- local verbosity="${GENTOO_DOTNET_BUILD_VERBOSITY:-minimal}"
+ local verbosity="${DOTNET_VERBOSITY:-minimal}"
ebegin "Building the .NET SDK ${SDK_SLOT}"
local -a buildopts=(
diff --git a/dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.101.ebuild b/dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.101.ebuild
index d5bce67a8124..5067599f96d7 100644
--- a/dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.101.ebuild
+++ b/dev-dotnet/dotnet-sdk/dotnet-sdk-9.0.101.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Pre-build (and distribution preparation)
@@ -15,7 +15,7 @@
# Build ("src_compile")
# To learn about arguments that are passed to the "build.sh" script see:
# https://github.com/dotnet/source-build/discussions/4082
-# User variable: GENTOO_DOTNET_BUILD_VERBOSITY - set other verbosity log level.
+# User variable: DOTNET_VERBOSITY - set other verbosity log level.
EAPI=8
@@ -245,7 +245,7 @@ src_compile() {
# The "source_repository" should always be the same.
local source_repository="https://github.com/dotnet/dotnet"
- local verbosity="${GENTOO_DOTNET_BUILD_VERBOSITY:-minimal}"
+ local verbosity="${DOTNET_VERBOSITY:-minimal}"
ebegin "Building the .NET SDK ${SDK_SLOT}"
local -a buildopts=(