summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-14 11:05:34 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-14 11:05:34 +0300
commitceee2a1084334429b297d5fab44f7b4a614b75d9 (patch)
treeb8e8f0602532875c5b037634004420b5ba1ad400 /dev-embedded
parentsci-libs/libsigrok: drop 0.5.2-r4 (diff)
downloadgentoo-ceee2a1084334429b297d5fab44f7b4a614b75d9.tar.gz
gentoo-ceee2a1084334429b297d5fab44f7b4a614b75d9.tar.bz2
gentoo-ceee2a1084334429b297d5fab44f7b4a614b75d9.zip
dev-embedded/avrdude: drop 7.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/avrdude/Manifest1
-rw-r--r--dev-embedded/avrdude/avrdude-7.0.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-embedded/avrdude/Manifest b/dev-embedded/avrdude/Manifest
index 9c081c4825fd..ab5c66389600 100644
--- a/dev-embedded/avrdude/Manifest
+++ b/dev-embedded/avrdude/Manifest
@@ -1,2 +1 @@
-DIST avrdude-7.0.tar.gz 2354082 BLAKE2B 44cc6cb82abd4e44f9e7f72901cd9b2a13c9e7635582993ea9a01ea482709ca6a8a3454980446d1196a67cec19a021133d5821731618350336f81fce09d7c049 SHA512 ca3338e6f2f0efc102e70f72531efbd237c5f7bc282d8db5530038f9e20b18a7c2682343bb2baff08c81f8959b066323a444dd64c2362a340a9d9708f90770e0
DIST avrdude-7.2.tar.gz 2622520 BLAKE2B 7bf86ea802bb150415a0d8c1ba884d5ff84b3d4bfb0e77470205d578001c1c19f782ddd37ae4235fba9f2ccc05247aea1723ebc2e1c71174c23b0986e835231e SHA512 04d04492458bc1d183ad8ff403cf3d38f65f44bb992df589e8f49d28b5347eb63433568c95f5d575ae651be70d725d3f178175cd1fe6dcd46ec013c3fe3f2ab0
diff --git a/dev-embedded/avrdude/avrdude-7.0.ebuild b/dev-embedded/avrdude/avrdude-7.0.ebuild
deleted file mode 100644
index 9acd4349f655..000000000000
--- a/dev-embedded/avrdude/avrdude-7.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="AVR Downloader/UploaDEr"
-HOMEPAGE="https://avrdudes.github.io/avrdude https://github.com/avrdudes/avrdude"
-SRC_URI="https://github.com/avrdudes/avrdude/archive/refs/tags/v${PV}.tar.gz -> avrdude-${PV}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="ftdi readline"
-
-RDEPEND="
- dev-libs/hidapi
- virtual/libelf:=
- virtual/libusb:0
- virtual/libusb:1
- ftdi? ( dev-embedded/libftdi:1= )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-alternatives/yacc
- app-alternatives/lex
-"
-
-src_prepare() {
- cmake_src_prepare
-
- # CMAKE_INSTALL_LIBDIR is not respected. Fixed in the next release.
- sed -i "s@DESTINATION lib@DESTINATION $(get_libdir)@g" \
- src/CMakeLists.txt || die
-
- # For some reason 'TYPE SYSCONF' and 'CMAKE_INSTALL_SYSCONFDIR'
- # prepends '/usr' so the config ends up getting installed as
- # '/usr/etc/avrdude.conf' which is not correct.
- sed -i 's@TYPE SYSCONF@DESTINATION ${CMAKE_INSTALL_FULL_SYSCONFDIR}@' \
- src/CMakeLists.txt || die
-}
-
-src_configure() {
- # Optional libraries like libftdi aren't gated behind options and
- # find_package calls, but find_library is called directly
- # instead.
- #
- # Set the cache variable to an empty string if we do not want a
- # library to be automatically detected.
- local mycmakeargs=(
- -DBUILD_DOC=OFF # This currently does nothing...
- -DBUILD_SHARED_LIBS=ON
- -DDEBUG_CMAKE=ON
- -DHAVE_LIBFTDI=''
- -DHAVE_LIBHID=''
- -DHAVE_LINUXGPIO=ON # Seems like there is no reason to have this off.
- -DHAVE_LINUXSPI=ON # Ditto.
- )
- use ftdi || mycmakeargs+=( -DHAVE_LIBFTDI1='' )
- use readline || mycmakeargs+=( -DHAVE_LIBREADLINE='' )
- cmake_src_configure
-}