summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/clock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/clock')
-rw-r--r--dev-haskell/clock/Manifest2
-rw-r--r--dev-haskell/clock/clock-0.4.1.3.ebuild31
-rw-r--r--dev-haskell/clock/clock-0.5.1.ebuild33
-rw-r--r--dev-haskell/clock/metadata.xml31
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-haskell/clock/Manifest b/dev-haskell/clock/Manifest
new file mode 100644
index 000000000000..c1fb07253b22
--- /dev/null
+++ b/dev-haskell/clock/Manifest
@@ -0,0 +1,2 @@
+DIST clock-0.4.1.3.tar.gz 5084 SHA256 0d38b2ecd60328b9b4ede572ff238d840e713da18e6ce002f08b82b01e7a1073 SHA512 515b5393e4db132a0cc201031f79d871b3e91d058fc59dd97d96e013d2d9b59cfc75ca76723d2dd90795bb855daf5b09f5b57384a75cfcf9251f41e3434eae35 WHIRLPOOL 6717eea2f6468ab998807aad0df1a4d042805188cbc65d02fa61e14408e97f4c84c2d1335b1550421d25e2a5ba03aa7f8c8b917809d389cd0d09803eac38f2e2
+DIST clock-0.5.1.tar.gz 6720 SHA256 7c7a1f89bc4fa2f995d31a214bb7e3ad44c3570cb46b8f18e7de6011f78197d9 SHA512 767ee279453838af962392a0d9f05e385d20877af79cd95f0444f6adbdec6cf14f7a6f60933df1ccd9e964725b057ecbc869ae270225adf495a87ec4c09a80b2 WHIRLPOOL c391d6914349ccca145e953a43aab5c87d922dcdcb0277178f521c7cc48e19d1d3eda2c92c4a8476a4f8ab7c427ed6725b3ed22eab585056d43397bf19416ef4
diff --git a/dev-haskell/clock/clock-0.4.1.3.ebuild b/dev-haskell/clock/clock-0.4.1.3.ebuild
new file mode 100644
index 000000000000..bd570a643e27
--- /dev/null
+++ b/dev-haskell/clock/clock-0.4.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -llvm
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="High-resolution clock functions: monotonic, realtime, cputime"
+HOMEPAGE="http://corsis.github.com/clock/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-llvm
+}
diff --git a/dev-haskell/clock/clock-0.5.1.ebuild b/dev-haskell/clock/clock-0.5.1.ebuild
new file mode 100644
index 000000000000..d38b48f3e0cc
--- /dev/null
+++ b/dev-haskell/clock/clock-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -llvm
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="High-resolution clock functions: monotonic, realtime, cputime"
+HOMEPAGE="https://github.com/corsis/clock"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/tasty-0.10
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-llvm
+}
diff --git a/dev-haskell/clock/metadata.xml b/dev-haskell/clock/metadata.xml
new file mode 100644
index 000000000000..87984412cdd0
--- /dev/null
+++ b/dev-haskell/clock/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A package for convenient access to high-resolution
+ clock and timer functions of different operating
+ systems.
+
+ It is planned to consist of two layers. The lower
+ layer will provide direct access to OS-specific
+ clock and timer functions like clock_gettime of
+ Posix or GetTickCount of Windows and its upper
+ layer shall then provide a common API for all
+ supported systems. Currently only the lower level
+ is being developed.
+
+
+ POSIX reference: IEEE Std 1003.1-2008
+ &lt;http://www.opengroup.org/onlinepubs/9699919799/&gt;,
+ &lt;http://www.opengroup.org/onlinepubs/9699919799/functions/clock_getres.html#&gt;
+
+ WINDOWS reference: ...
+
+ For more information, see:
+ &lt;http://corsis.sourceforge.net/index.php/Haskell/Clock&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">corsis/clock</remote-id>
+ </upstream>
+</pkgmetadata>