summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:06:58 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:26 +0100
commite56faf61e0418ac5c8647d2472a296118927eab5 (patch)
tree2b7de389c7d749b16911cdca820a259414fbeec7 /dev-haskell/data-fix
parentdev-haskell/cryptonite: add 0.30 (diff)
downloadgentoo-e56faf61e0418ac5c8647d2472a296118927eab5.tar.gz
gentoo-e56faf61e0418ac5c8647d2472a296118927eab5.tar.bz2
gentoo-e56faf61e0418ac5c8647d2472a296118927eab5.zip
dev-haskell/data-fix: Hackage revision bump
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/data-fix')
-rw-r--r--dev-haskell/data-fix/Manifest2
-rw-r--r--dev-haskell/data-fix/data-fix-0.3.2-r1.ebuild26
-rw-r--r--dev-haskell/data-fix/data-fix-0.3.2.ebuild38
-rw-r--r--dev-haskell/data-fix/metadata.xml4
4 files changed, 31 insertions, 39 deletions
diff --git a/dev-haskell/data-fix/Manifest b/dev-haskell/data-fix/Manifest
index e19ca61a3ddf..844a1504279d 100644
--- a/dev-haskell/data-fix/Manifest
+++ b/dev-haskell/data-fix/Manifest
@@ -1,2 +1,2 @@
-DIST data-fix-0.3.2.cabal 1692 BLAKE2B 09b59f90198d3982c5ed0904a082b00348ed210872f972d2b3bcd8c3507c0af659e879d72f630b42b32ead16fec3a18c42ba462122b1a44ddb2ca8d60f7dc214 SHA512 353aacd3740c247f692be7256a59824fa35512a121d356515e9b87e204a6a68c6add8f14111a47f8930aac386d85ea2494b09d06b34ca939e2838de79834c923
+DIST data-fix-0.3.2-rev4.cabal 1720 BLAKE2B 804bae8c1788c3ad572e128274b24e62cd8c53cd44d3079acec348f5d3f0a663b258c040b9d3b8fa1463b1b292a30c954121e5f4aea697115f416557a1b5fa59 SHA512 6577a28f2451c9fe88fe5dbabdcfccabad8e5654491f00cace75df8273ec3c0e2fd2dc3fbc9347051a67214499ff56b077c29f020753e5fee647e52f2083b4d0
DIST data-fix-0.3.2.tar.gz 5842 BLAKE2B b59f0e2abd572945219355206f24f689835026d4adb6ce4d85073f11a8742701463dfe6029376d5a65959c61115483cfb00f557213c222b18a28e9336a4f3879 SHA512 70b0c15522ea1fa623397bd399d83cc0921736012e6daaad21a9940ec9f447373f7e0e3915369127c7c54def7cb1d066c4641e676fa5f444f3d5dd761c258b63
diff --git a/dev-haskell/data-fix/data-fix-0.3.2-r1.ebuild b/dev-haskell/data-fix/data-fix-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..9bf501127acd
--- /dev/null
+++ b/dev-haskell/data-fix/data-fix-0.3.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Fixpoint data types"
+HOMEPAGE="https://github.com/spell-music/data-fix"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
diff --git a/dev-haskell/data-fix/data-fix-0.3.2.ebuild b/dev-haskell/data-fix/data-fix-0.3.2.ebuild
deleted file mode 100644
index d44dacaa2906..000000000000
--- a/dev-haskell/data-fix/data-fix-0.3.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.1.1.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-CABAL_HACKAGE_REVISION="2"
-inherit haskell-cabal
-
-DESCRIPTION="Fixpoint data types"
-HOMEPAGE="https://github.com/spell-music/data-fix"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
- https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-
-RDEPEND=">=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
- >=dev-lang/ghc-8.4.3:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
-"
-BDEPEND="app-text/dos2unix"
-
-src_prepare() {
- # pull revised cabal from upstream
- cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
-
- # Convert to unix line endings
- dos2unix "${S}/${PN}.cabal" || die
-
- # Apply patches *after* pulling the revised cabal
- default
-}
diff --git a/dev-haskell/data-fix/metadata.xml b/dev-haskell/data-fix/metadata.xml
index 937381521944..29898652b264 100644
--- a/dev-haskell/data-fix/metadata.xml
+++ b/dev-haskell/data-fix/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">data-fix</remote-id>
+ <remote-id type="github">spell-music/data-fix</remote-id>
+ </upstream>
</pkgmetadata>