summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:07 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:29 +0100
commit8b34964ffca47e9a072327b4c368982ee56be232 (patch)
treefc0cb7434c3b57951d27b00d84b65edf119af3eb /dev-haskell/echo
parentdev-haskell/doctest: add 0.22.0 (diff)
downloadgentoo-8b34964ffca47e9a072327b4c368982ee56be232.tar.gz
gentoo-8b34964ffca47e9a072327b4c368982ee56be232.tar.bz2
gentoo-8b34964ffca47e9a072327b4c368982ee56be232.zip
dev-haskell/echo: add 0.1.4-r1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/echo')
-rw-r--r--dev-haskell/echo/Manifest1
-rw-r--r--dev-haskell/echo/echo-0.1.4-r1.ebuild35
-rw-r--r--dev-haskell/echo/metadata.xml18
3 files changed, 40 insertions, 14 deletions
diff --git a/dev-haskell/echo/Manifest b/dev-haskell/echo/Manifest
index 6baae75f099a..f8fc2b0513fb 100644
--- a/dev-haskell/echo/Manifest
+++ b/dev-haskell/echo/Manifest
@@ -1 +1,2 @@
DIST echo-0.1.3.tar.gz 5373 BLAKE2B 3710de35b42e39f7ff9d2e5c2e32ae4c1e863f9ae844ada25dbb653aafd6ed261357c3b5046e9e0cabb03dd4de4f6252272a2b643087a61d1df5f26de329e588 SHA512 26a2398af231a8805b6b0a866348f848b8b8f21fe95a2fa3c781aaeae150df978335df573d46d5b07d7e4df19d6377d997f85c77049abaf0c5cb3e9998439c6f
+DIST echo-0.1.4.tar.gz 5501 BLAKE2B 948f5894bc67ab80423ac725c3202fcfb8e032ca73440f16c658486219ab63bd8181f1120a4bbd92834bb3a8695222cb5e3491d5dbd26045d012a90370b1a80a SHA512 25fa868be5cbbc96adb4457b0e6a2fb7060b889e0dead9acef21038fd438d1ca1ee3c57ee03d91f75271e97cfea71b1d3589f800af70e15cb8cee6a60e041477
diff --git a/dev-haskell/echo/echo-0.1.4-r1.ebuild b/dev-haskell/echo/echo-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..e79965cb0d4c
--- /dev/null
+++ b/dev-haskell/echo/echo-0.1.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A cross-platform, cross-console way to handle echoing terminal input"
+HOMEPAGE="https://github.com/RyanGlScott/echo"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+# Change example name to avoid name collisions
+CABAL_CHDEPS=(
+ 'executable password' 'executable haskell-echo-example'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples example)
+}
diff --git a/dev-haskell/echo/metadata.xml b/dev-haskell/echo/metadata.xml
index 9d0d8cfdb8a6..db0e8f939661 100644
--- a/dev-haskell/echo/metadata.xml
+++ b/dev-haskell/echo/metadata.xml
@@ -5,18 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The @base@ library exposes the @hGetEcho@ and @hSetEcho@ functions
- for querying and setting echo status, but unfortunately, neither
- function works with MinTTY consoles on Windows. This is a serious
- issue, since @hGetEcho@ and @hSetEcho@ are often used to disable
- input echoing when a program prompts for a password, so many
- programs will reveal your password as you type it on MinTTY!
-
- This library provides an alternative interface which works
- with both MinTTY and other consoles. An example is included
- which demonstrates how one might prompt for a password using
- this library. To build it, make sure to configure with the
- @-fexample@ flag.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">echo</remote-id>
+ <remote-id type="github">RyanGlScott/echo</remote-id>
+ </upstream>
</pkgmetadata>