summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:23:37 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-22 22:31:16 +0100
commit4a5dcbf34470c6ec171bbb3afd02312953463b8c (patch)
tree6206bd4c1fae321b7cc21a05fa2c58163e9b30d0 /dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild
parentdev-haskell/primitive-addr: new package, a depend of arithmoi-0.11 (diff)
downloadgentoo-4a5dcbf34470c6ec171bbb3afd02312953463b8c.tar.gz
gentoo-4a5dcbf34470c6ec171bbb3afd02312953463b8c.tar.bz2
gentoo-4a5dcbf34470c6ec171bbb3afd02312953463b8c.zip
dev-haskell/quickcheck-classes: new package, a depend of arithmoi-0.11
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild')
-rw-r--r--dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild b/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild
new file mode 100644
index 000000000000..e4dbaa884075
--- /dev/null
+++ b/dev-haskell/quickcheck-classes/quickcheck-classes-0.6.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck common typeclasses"
+HOMEPAGE="https://github.com/andrewthad/quickcheck-classes#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+aeson +binary-laws +semigroupoids +semirings +unary-laws +vector"
+
+RDEPEND=">=dev-haskell/base-orphans-0.1:=[profile?]
+ dev-haskell/bifunctors:=[profile?]
+ dev-haskell/contravariant:=[profile?]
+ dev-haskell/fail:=[profile?]
+ >=dev-haskell/primitive-0.6.4:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/primitive-addr-0.1.0.2:=[profile?] <dev-haskell/primitive-addr-0.2:=[profile?]
+ >=dev-haskell/quickcheck-classes-base-0.6:=[profile?] <dev-haskell/quickcheck-classes-base-0.7:=[profile?]
+ >=dev-haskell/semigroups-0.17:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ aeson? ( >=dev-haskell/aeson-0.9:=[profile?] )
+ binary-laws? ( >=dev-haskell/quickcheck-2.10.0:2=[profile?] )
+ semigroupoids? ( dev-haskell/semigroupoids:=[profile?] )
+ semirings? ( >=dev-haskell/semirings-0.4.2:=[profile?] )
+ unary-laws? ( >=dev-haskell/quickcheck-2.10.0:2=[profile?] )
+ !unary-laws? ( !binary-laws? ( >=dev-haskell/quickcheck-2.7:2=[profile?] ) )
+ vector? ( >=dev-haskell/vector-0.12:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/base-orphans-0.5
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck
+ !vector? ( dev-haskell/vector ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag aeson aeson) \
+ $(cabal_flag binary-laws binary-laws) \
+ $(cabal_flag semigroupoids semigroupoids) \
+ $(cabal_flag semirings semirings) \
+ $(cabal_flag unary-laws unary-laws) \
+ $(cabal_flag vector vector)
+}