summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/wai-app-static
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/wai-app-static')
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-1.3.2.1.ebuild4
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-2.0.0.3.ebuild4
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-3.0.1.ebuild4
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild4
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-3.1.6.1.ebuild4
5 files changed, 10 insertions, 10 deletions
diff --git a/dev-haskell/wai-app-static/wai-app-static-1.3.2.1.ebuild b/dev-haskell/wai-app-static/wai-app-static-1.3.2.1.ebuild
index fac1660cf64d..ffd4d7f66db1 100644
--- a/dev-haskell/wai-app-static/wai-app-static-1.3.2.1.ebuild
+++ b/dev-haskell/wai-app-static/wai-app-static-1.3.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="WAI application for static serving"
HOMEPAGE="https://www.yesodweb.com/book/web-application-interface"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
diff --git a/dev-haskell/wai-app-static/wai-app-static-2.0.0.3.ebuild b/dev-haskell/wai-app-static/wai-app-static-2.0.0.3.ebuild
index 6b7dcfc70b72..77d5851f6dd0 100644
--- a/dev-haskell/wai-app-static/wai-app-static-2.0.0.3.ebuild
+++ b/dev-haskell/wai-app-static/wai-app-static-2.0.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="WAI application for static serving"
HOMEPAGE="https://www.yesodweb.com/book/web-application-interface"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
diff --git a/dev-haskell/wai-app-static/wai-app-static-3.0.1.ebuild b/dev-haskell/wai-app-static/wai-app-static-3.0.1.ebuild
index 8df2b47fcf8d..6af5576e0fd7 100644
--- a/dev-haskell/wai-app-static/wai-app-static-3.0.1.ebuild
+++ b/dev-haskell/wai-app-static/wai-app-static-3.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="WAI application for static serving"
HOMEPAGE="https://www.yesodweb.com/book/web-application-interface"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
diff --git a/dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild b/dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild
index 270c79366a3d..42c45884f9d7 100644
--- a/dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild
+++ b/dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="WAI application for static serving"
HOMEPAGE="https://www.yesodweb.com/book/web-application-interface"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
diff --git a/dev-haskell/wai-app-static/wai-app-static-3.1.6.1.ebuild b/dev-haskell/wai-app-static/wai-app-static-3.1.6.1.ebuild
index 0a891f5c239a..0bfa63fbba5f 100644
--- a/dev-haskell/wai-app-static/wai-app-static-3.1.6.1.ebuild
+++ b/dev-haskell/wai-app-static/wai-app-static-3.1.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ inherit haskell-cabal
DESCRIPTION="WAI application for static serving"
HOMEPAGE="https://www.yesodweb.com/book/web-application-interface"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"