summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-12-02 10:30:32 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-12-03 10:05:16 +0100
commit8e50a6026d27fd3deec692ea7fd723ef4ec198a6 (patch)
tree5697e1497d3964abb5f661e2951bdd2b0f55a362 /dev-java/commons-collections
parentdev-java/commons-collections: slot 4, max jdk 17 (diff)
downloadgentoo-8e50a6026d27fd3deec692ea7fd723ef4ec198a6.tar.gz
gentoo-8e50a6026d27fd3deec692ea7fd723ef4ec198a6.tar.bz2
gentoo-8e50a6026d27fd3deec692ea7fd723ef4ec198a6.zip
dev-java/commons-collections: minor style update (slot 4)
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/33587 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/commons-collections-4.4-r2.ebuild51
1 files changed, 19 insertions, 32 deletions
diff --git a/dev-java/commons-collections/commons-collections-4.4-r2.ebuild b/dev-java/commons-collections/commons-collections-4.4-r2.ebuild
index cebe177a6358..059e87b91233 100644
--- a/dev-java/commons-collections/commons-collections-4.4-r2.ebuild
+++ b/dev-java/commons-collections/commons-collections-4.4-r2.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://apache/commons/collections/source/commons-collections4-4.4-src.tar.gz --slot 4 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild commons-collections-4.4.ebuild
-
EAPI=8
JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="org.apache.commons:commons-collections4:4.4"
+MAVEN_ID="org.apache.commons:commons-collections4:${PV}"
JAVA_TESTING_FRAMEWORKS="junit-4"
inherit java-pkg-2 java-pkg-simple verify-sig
@@ -16,17 +13,12 @@ DESCRIPTION="Extends the JCF classes with new interfaces, implementations and ut
HOMEPAGE="https://commons.apache.org/proper/commons-collections/"
SRC_URI="mirror://apache/commons/collections/source/${PN}4-${PV}-src.tar.gz
verify-sig? ( https://downloads.apache.org/commons/collections/source/${PN}4-${PV}-src.tar.gz.asc )"
+S="${WORKDIR}/commons-collections4-${PV}-src"
LICENSE="Apache-2.0"
SLOT="4"
KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-# Compile dependencies
-# POM: pom.xml
-# test? junit:junit:4.12 -> >=dev-java/junit-4.13.2:4
-# test? org.apache.commons:commons-lang3:3.9 -> >=dev-java/commons-lang-3.12.0:3.6
-# test? org.easymock:easymock:4.0.2 -> !!!suitable-mavenVersion-not-found!!!
-
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/commons.apache.org.asc"
BDEPEND="verify-sig? ( sec-keys/openpgp-keys-apache-commons )"
# broken with jdk:21 - https://bugs.gentoo.org/916445
@@ -37,36 +29,31 @@ DEPEND="
dev-java/commons-lang:3.6
)
"
+RDEPEND=">=virtual/jre-1.8:*"
-RDEPEND="
- >=virtual/jre-1.8:*
-"
-
-DOCS=( {CONTRIBUTING,README}.md {LICENSE,NOTICE,RELEASE-NOTES}.txt )
+DOCS=( {CONTRIBUTING,README}.md {NOTICE,RELEASE-NOTES}.txt )
HTML_DOCS=( {DEVELOPERS-GUIDE,PROPOSAL}.html )
-S="${WORKDIR}/commons-collections4-${PV}-src"
-
+JAVA_AUTOMATIC_MODULE_NAME="org.apache.commons.collections4"
JAVA_SRC_DIR="src/main/java"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit-4,commons-lang-3.6,easymock-3.2"
-JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_GENTOO_CLASSPATH="
+ commons-lang-3.6
+ easymock-3.2
+ junit-4
+"
JAVA_TEST_RESOURCE_DIRS="src/test/resources"
-JAVA_AUTOMATIC_MODULE_NAME="org.apache.commons.collections4"
+JAVA_TEST_SRC_DIR="src/test/java"
src_test() {
- # https://github.com/apache/commons-collections/blob/cab58b3a8093a2f6b84f12783a3fb358747310f7/pom.xml#L542-L550
+ # https://github.com/apache/commons-collections/blob/commons-commons-collections-4.4/pom.xml#L542-L550
pushd src/test/java || die
- local TESTS=$(find * -name "*Test.java" ! -name "TestUtils.java" ! -name "Abstract*.java" ! -name "BulkTest.java")
- TESTS="${TESTS//.java}"
- TESTS="${TESTS//\//.}"
+ local JAVA_TEST_RUN_ONLY=$(find * \
+ -name "*Test.java" \
+ ! -name "TestUtils.java" \
+ ! -name "Abstract*.java" \
+ ! -name "BulkTest.java")
+ JAVA_TEST_RUN_ONLY="${JAVA_TEST_RUN_ONLY//.java}"
+ JAVA_TEST_RUN_ONLY="${JAVA_TEST_RUN_ONLY//\//.}"
popd
-
- JAVA_TEST_RUN_ONLY=( "${TESTS}" )
java-pkg-simple_src_test
}
-
-src_install() {
- default # https://bugs.gentoo.org/789582
- java-pkg-simple_src_install
-}