summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/edtftpj
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/edtftpj')
-rw-r--r--dev-java/edtftpj/Manifest1
-rw-r--r--dev-java/edtftpj/edtftpj-2.0.4.ebuild44
-rw-r--r--dev-java/edtftpj/metadata.xml16
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/edtftpj/Manifest b/dev-java/edtftpj/Manifest
new file mode 100644
index 000000000000..f66085af62c1
--- /dev/null
+++ b/dev-java/edtftpj/Manifest
@@ -0,0 +1 @@
+DIST edtftpj-2.0.4.zip 1314543 SHA256 e24e1b883254ed28312412ddabb07fab0d9022fcedb78901c804b94c659c3666 SHA512 6af25752e794ece897fe0758dd373f583c7960b5ffe01eefe2947bcd0ab73619876c6ae2557f5ce3e039839a6b41581d29be6c2fee568ddc2bb668216ae04e3e WHIRLPOOL 93b1c380ed61feeae50f1e975c9485802a54de9ddc362b396ff0db70f844138c0198b4a5e94592a1a50c38058911457e6a882a39a1a15560697535422d39ef5e
diff --git a/dev-java/edtftpj/edtftpj-2.0.4.ebuild b/dev-java/edtftpj/edtftpj-2.0.4.ebuild
new file mode 100644
index 000000000000..168d6dc0c43b
--- /dev/null
+++ b/dev-java/edtftpj/edtftpj-2.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="FTP client library written in Java"
+SRC_URI="http://www.enterprisedt.com/products/edtftpj/download/${P}.zip"
+HOMEPAGE="http://www.enterprisedt.com"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND=">=virtual/jre-1.4
+ =dev-java/junit-3.8*"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${RDEPEND}"
+
+java_prepare() {
+ find . '(' -name '*.class' -o -name '*.jar' ')' -print -delete
+
+ rm doc/LICENSE.TXT || die "Failed to remove LICENSE.TXT"
+}
+
+src_compile() {
+ cd src || die
+
+ eant jar -Dftp.classpath=$(java-pkg_getjars junit) $(use_doc javadocs)
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+
+ use doc && java-pkg_dojavadoc build/doc/api
+ use source && java-pkg_dosrc src/com
+ use examples && java-pkg_doexamples examples
+}
diff --git a/dev-java/edtftpj/metadata.xml b/dev-java/edtftpj/metadata.xml
new file mode 100644
index 000000000000..78e4b70b2dfe
--- /dev/null
+++ b/dev-java/edtftpj/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ edtFTPj is the first choice of Java developers worldwide
+ for incorporating FTP functionality into their applications.
+ edtFTPj is Open Source, licensed under the LGPL, the GNU
+ Lesser General Public License. This means you can freely
+ embed edtFTPj into your commercial Java applications,
+ subject to the normal LGPL restrictions. Unrestricted
+ (non-GPL) source licenses can be also be purchased. edtFTPj
+ has been downloaded over 100,000 times since its first
+ release, and is in use in thousands of companies worldwide.
+ </longdescription>
+</pkgmetadata>