summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdbc2-stdext
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdbc2-stdext')
-rw-r--r--dev-java/jdbc2-stdext/Manifest1
-rw-r--r--dev-java/jdbc2-stdext/jdbc2-stdext-2.0-r3.ebuild71
-rw-r--r--dev-java/jdbc2-stdext/metadata.xml5
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-java/jdbc2-stdext/Manifest b/dev-java/jdbc2-stdext/Manifest
new file mode 100644
index 000000000000..2e1a72d534f8
--- /dev/null
+++ b/dev-java/jdbc2-stdext/Manifest
@@ -0,0 +1 @@
+DIST jdbc2_0-stdext-src.zip 21642 SHA256 70470d9f3a2e1f4e29b909bf9c89005a9d2523825eb50cf70b2fa2957ff8b2aa SHA512 5157a5835983c094b13d947a39311d08ea57cd8e60197176681289d41a209f3f8b464e1e0dd97ed714534ba5afb749807e02efb3edba4e2c91e273e71f6f1ce3 WHIRLPOOL a57f77ae2b268b21e7733b7cf4edf1cd8751c8c5c25f1b7a6ae78677c14d5f499a9a05c36cd88a3c9ec9c4fc361476cc7433fa81cb94ed51b09ac4a2bca341a5
diff --git a/dev-java/jdbc2-stdext/jdbc2-stdext-2.0-r3.ebuild b/dev-java/jdbc2-stdext/jdbc2-stdext-2.0-r3.ebuild
new file mode 100644
index 000000000000..f7926bff22f9
--- /dev/null
+++ b/dev-java/jdbc2-stdext/jdbc2-stdext-2.0-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2
+
+stdext_src="jdbc2_0-stdext-src.zip"
+stdext_jar="jdbc2-stdext.jar"
+
+DESCRIPTION="A standard set of libs for Server-Side JDBC support"
+HOMEPAGE="http://www.oracle.com/technetwork/java/index.html"
+SRC_URI="${stdext_src}"
+
+LICENSE="Oracle-BCLA-JavaSE"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="fetch"
+
+RDEPEND="
+ >=virtual/jre-1.4"
+
+DEPEND="
+ >=virtual/jdk-1.4
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ local download_url="http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-database-419422.html#7099-jdbc-2.0-src-oth-JPR"
+
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${download_url}"
+ einfo " 2. Select 'JDBC Standard Extension Source 2.0'"
+ einfo " 3. Download ${stdext_src}"
+ einfo " 4. Move to ${DISTDIR}"
+ einfo
+ einfo " Run emerge on this package again to complete"
+ einfo
+}
+
+src_unpack() {
+ mkdir src || die
+ cd src || die
+ unpack ${A}
+}
+
+src_compile() {
+ mkdir classes || die
+ ejavac -d classes src/javax/sql/*.java
+ jar cf "${stdext_jar}" -C classes/ . || die "jar failed"
+
+ if use doc; then
+ javadoc -d api -source $(java-pkg_get-source) -sourcepath src/ \
+ javax.sql || die "javadoc failed"
+ fi
+}
+
+src_install() {
+ java-pkg_dojar "${stdext_jar}"
+
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jdbc2-stdext/metadata.xml b/dev-java/jdbc2-stdext/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/jdbc2-stdext/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>