summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xerial-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xerial-core')
-rw-r--r--dev-java/xerial-core/Manifest1
-rw-r--r--dev-java/xerial-core/files/2.0.1-build.xml140
-rw-r--r--dev-java/xerial-core/metadata.xml9
-rw-r--r--dev-java/xerial-core/xerial-core-2.0.1.ebuild42
4 files changed, 192 insertions, 0 deletions
diff --git a/dev-java/xerial-core/Manifest b/dev-java/xerial-core/Manifest
new file mode 100644
index 000000000000..bb7174ad4cd2
--- /dev/null
+++ b/dev-java/xerial-core/Manifest
@@ -0,0 +1 @@
+DIST xerial-core-2.0.1.tar.bz2 519709 SHA256 18fc5948ef4007edeb8c373c4b28057f08aa20a3514ed257cf592ee8db7437a1 SHA512 39236e8a653301a6899ce80d3240d505e91f0cfc8878fa1a698113d06f3af3fd7adef540d72da1c0e1fb7101542c43e92fb9388243d95c3185a561532c18c6fb WHIRLPOOL 860729ac4badeff692f603cd6d0e31b21e3876833c9f6c9d4a31e0c9bd95e7ccef0c924477cf0fdf525877625ef24f66b3fe6183c484381d577bd4a56aa602e6
diff --git a/dev-java/xerial-core/files/2.0.1-build.xml b/dev-java/xerial-core/files/2.0.1-build.xml
new file mode 100644
index 000000000000..76a6adfcb189
--- /dev/null
+++ b/dev-java/xerial-core/files/2.0.1-build.xml
@@ -0,0 +1,140 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<project name="xerial-core-from-maven" default="package" basedir=".">
+ <property file="${user.home}/.m2/maven.properties" />
+ <property file="maven-build.properties" />
+
+ <property name="maven.build.finalName" value="xerial-core-2.0.1" />
+ <property name="maven.build.dir" value="target" />
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes" />
+ <property name="maven.build.srcDir.0" value="src/main/java" />
+ <property name="maven.build.resourceDir.0" value="src/main/java" />
+ <property name="maven.build.resourceDir.1" value="src/main/resources" />
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes" />
+ <property name="maven.build.testDir.0" value="src/test/java" />
+ <property name="maven.build.testResourceDir.0" value="src/test/java" />
+ <property name="maven.build.testResourceDir.1" value="src/test/resources" />
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports" />
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site" />
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository" />
+ <property name="maven.settings.offline" value="false" />
+ <property name="maven.settings.interactiveMode" value="true" />
+
+ <path id="build.classpath" />
+ <path id="build.test.classpath" />
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}" />
+ </target>
+
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}" />
+ <javac destdir="${maven.build.outputDir}" nowarn="false" debug="true" optimize="false" deprecation="true" target="1.6" verbose="false" fork="false" source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}" />
+ </src>
+ <classpath refid="build.classpath" />
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <exclude name="**/*.java" />
+ </fileset>
+ </copy>
+ </target>
+
+
+ <target name="compile-tests" depends="compile" description="Compile the test code" unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}" />
+ <javac destdir="${maven.build.testOutputDir}" nowarn="false" debug="true" optimize="false" deprecation="true" target="1.6" verbose="false" fork="false" source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}" />
+ </src>
+ <classpath>
+ <path refid="build.test.classpath" />
+ <pathelement location="${maven.build.outputDir}" />
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}">
+ <exclude name="**/*.java" />
+ </fileset>
+ </copy>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.1}" />
+ </copy>
+ </target>
+
+ <target name="test" depends="compile-tests, junit-missing" unless="junit.skipped" description="Run the test cases">
+ <mkdir dir="${maven.test.reports}" />
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="." />
+ <formatter type="xml" />
+ <formatter type="plain" usefile="false" />
+ <classpath>
+ <path refid="build.test.classpath" />
+ <pathelement location="${maven.build.outputDir}" />
+ <pathelement location="${maven.build.testOutputDir}" />
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java" />
+ <include name="**/*Test.java" />
+ <include name="**/*TestCase.java" />
+ <exclude name="**/*Abstract*Test.java" />
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java" />
+ <exclude name="**/*Abstract*Test.java" />
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" />
+ </target>
+
+ <target name="test-junit-status" depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}" />
+ <isfalse value="${maven.test.skip}" />
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}" />
+ <istrue value="${maven.test.skip}" />
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing" depends="test-junit-status" if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}" packagenames="*" destdir="${maven.reporting.outputDirectory}/apidocs" charset="ISO-8859-1" linksource="false" breakiterator="false">
+ <doctitle>&lt;![CDATA[xerial-core-2.0.1 API]]&gt;</doctitle>
+ </javadoc>
+ </target>
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar" compress="true" index="false" basedir="${maven.build.outputDir}" excludes="**/package.html" />
+ </target>
+
+ <target name="jar" depends="package" description="Builds the jar for the application" />
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true" />
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/xerial-core/metadata.xml b/dev-java/xerial-core/metadata.xml
new file mode 100644
index 000000000000..e39d18f86245
--- /dev/null
+++ b/dev-java/xerial-core/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="google-code">xerial</remote-id>
+ </upstream>
+</pkgmetadata>
+
diff --git a/dev-java/xerial-core/xerial-core-2.0.1.ebuild b/dev-java/xerial-core/xerial-core-2.0.1.ebuild
new file mode 100644
index 000000000000..cd20c8daa304
--- /dev/null
+++ b/dev-java/xerial-core/xerial-core-2.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="An open-source DBMS for XML/JSON/Relational data"
+HOMEPAGE="https://code.google.com/p/xerial/"
+SRC_URI="http://dev.gentoo.org/~ercpe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )"
+RDEPEND=">=virtual/jre-1.6"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+EANT_TEST_ANT_TASKS="ant-junit"
+
+java_prepare() {
+ cp "${FILESDIR}"/${PV}-build.xml "${S}"/build.xml || die
+}
+
+src_install() {
+ java-pkg_newjar "${S}/target/${P}.jar" "${PN}.jar"
+
+ use source && java-pkg_dosrc "${S}"/src/main/java/*
+ use doc && java-pkg_dojavadoc "${S}"/target/site/apidocs
+}
+
+src_test() {
+ java-pkg-2_src_test
+}