summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-21 08:09:16 +0100
committerSam James <sam@gentoo.org>2021-04-21 19:49:32 +0100
commitc67c56108e539dea07a440001c20da4c1bf1325d (patch)
treeb4e25021a728f6ac545c98fbc19ddaf5c3620725 /dev-lang/go/go-9999.ebuild
parentdev-lang/execline: fix function declaration style (braces) (diff)
downloadgentoo-c67c56108e539dea07a440001c20da4c1bf1325d.tar.gz
gentoo-c67c56108e539dea07a440001c20da4c1bf1325d.tar.bz2
gentoo-c67c56108e539dea07a440001c20da4c1bf1325d.zip
dev-lang/go: fix function declaration style (braces)
Package-Manager: Portage-3.0.18-prefix, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/go/go-9999.ebuild')
-rw-r--r--dev-lang/go/go-9999.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 39d69abc7b52..9d3bb807e833 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -55,8 +55,7 @@ PATENTS
README.md
)
-go_arch()
-{
+go_arch() {
# By chance most portage arch names match Go
local portage_arch=$(tc-arch $@)
case "${portage_arch}" in
@@ -68,8 +67,7 @@ go_arch()
esac
}
-go_arm()
-{
+go_arm() {
case "${1:-${CHOST}}" in
armv5*) echo 5;;
armv6*) echo 6;;
@@ -80,8 +78,7 @@ go_arm()
esac
}
-go_os()
-{
+go_os() {
case "${1:-${CHOST}}" in
*-linux*) echo linux;;
*-darwin*) echo darwin;;
@@ -98,18 +95,15 @@ go_os()
esac
}
-go_tuple()
-{
+go_tuple() {
echo "$(go_os $@)_$(go_arch $@)"
}
-go_cross_compile()
-{
+go_cross_compile() {
[[ $(go_tuple ${CBUILD}) != $(go_tuple) ]]
}
-src_compile()
-{
+src_compile() {
if has_version -b dev-lang/go; then
export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go"
elif has_version -b dev-lang/go-bootstrap; then
@@ -140,8 +134,7 @@ src_compile()
bash -x ./make.bash || die "build failed"
}
-src_test()
-{
+src_test() {
go_cross_compile && return 0
cd src
@@ -152,8 +145,7 @@ src_test()
rm -fr pkg/obj/go-build || die
}
-src_install()
-{
+src_install() {
# There is a known issue which requires the source tree to be installed [1].
# Once this is fixed, we can consider using the doc use flag to control
# installing the doc and src directories.