summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-10-09 11:34:35 -0400
committerMichał Górny <mgorny@gentoo.org>2023-10-19 17:13:16 +0200
commit7cabea64c858b3d5bc30db0fd4f2a47d1d4b724d (patch)
tree97c8981cfda6d59cf40cbb646f57ed9df9356c60 /dev-lang
parentdev-libs/libclc: Fix EmptyGlobalAssignment (diff)
downloadgentoo-7cabea64c858b3d5bc30db0fd4f2a47d1d4b724d.tar.gz
gentoo-7cabea64c858b3d5bc30db0fd4f2a47d1d4b724d.tar.bz2
gentoo-7cabea64c858b3d5bc30db0fd4f2a47d1d4b724d.zip
dev-lang/ispc: drop 1.18.0
Closes: https://bugs.gentoo.org/905161 Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/33263 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/Manifest1
-rw-r--r--dev-lang/ispc/ispc-1.18.0.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index 188333b63a8f..5dc60d213eaa 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,2 +1 @@
-DIST ispc-1.18.0.tar.gz 19469764 BLAKE2B dd95ec177120899066d5539add0f35685d73f65512e8be1cc42cf6725741d7f307fbecefc22c4944d9be0e3659d511546b15506213f3dbb97829953507996283 SHA512 350b43876d6885ab4c5c0d49c5b44323fd258d5cf7c68fcdea774baa92589542f2caeea93c347a37f0dab3dcf14e7b3e685973b41694f08ce7a2da64dc81bf06
DIST ispc-1.19.0.tar.gz 19577782 BLAKE2B 5ad6eeeeb0bb27f2a27267a26a729693bd16250ae5e8740728290fe6ad85c7ecd4da40f316f2ca6b1447ff3a13f6949db4ed2af6ebf2c6ce6ba43620dfb1943d SHA512 140f16bc0f9e0a94853b50a5433be9196ee09b6c70a1840d400d0d201143da8cb2b1b92a857acf5856ed3410bfffd17678eb1029996f9007fe947f5ac78bf1bb
diff --git a/dev-lang/ispc/ispc-1.18.0.ebuild b/dev-lang/ispc/ispc-1.18.0.ebuild
deleted file mode 100644
index a343a4857794..000000000000
--- a/dev-lang/ispc/ispc-1.18.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-LLVM_MAX_SLOT=14
-inherit cmake python-any-r1 llvm
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.io/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ispc/ispc.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="<sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):="
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- ${PYTHON_DEPS}
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.18.0-llvm.patch
- "${FILESDIR}"/${PN}-1.18.0-curses-cmake.patch
-)
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- if use amd64; then
- # On amd64 systems, build system enables x86/i686 build too.
- # This ebuild doesn't even have multilib support, nor need it.
- # https://bugs.gentoo.org/730062
- ewarn "Removing auto-x86 build on amd64"
- sed -i -e 's:set(target_arch "i686"):return():' cmake/GenerateBuiltins.cmake || die
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DARM_ENABLED=$(usex arm)
- -DCMAKE_SKIP_RPATH=ON
- -DISPC_NO_DUMPS=ON
- -DISPC_INCLUDE_EXAMPLES=OFF
- -DISPC_INCLUDE_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-src_test() {
- # Inject path to prevent using system ispc
- PATH="${BUILD_DIR}/bin:${PATH}" ${EPYTHON} ./run_tests.py || die "Testing failed under ${EPYTHON}"
-}
-
-src_install() {
- dobin "${BUILD_DIR}"/bin/ispc
- einstalldocs
-
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- dodoc -r examples
- fi
-}