summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-04-10 18:40:33 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-04-10 18:40:33 +0200
commit81057e83b3f4f4d8829f8f2156355457dfc2aa6f (patch)
treeabf447ccb578bb3cb7c057c0b39d8aee3f7e7e33 /dev-libs/ffcall/ffcall-2.1.ebuild
parentdev-php/maxmind-db-reader: Version bump to 1.3.0 (diff)
downloadgentoo-81057e83b3f4f4d8829f8f2156355457dfc2aa6f.tar.gz
gentoo-81057e83b3f4f4d8829f8f2156355457dfc2aa6f.tar.bz2
gentoo-81057e83b3f4f4d8829f8f2156355457dfc2aa6f.zip
dev-libs/ffcall: Version bump to 2.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs/ffcall/ffcall-2.1.ebuild')
-rw-r--r--dev-libs/ffcall/ffcall-2.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/ffcall/ffcall-2.1.ebuild b/dev-libs/ffcall/ffcall-2.1.ebuild
new file mode 100644
index 000000000000..b4762103c805
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_PV="libffcall-${PV}"
+
+DESCRIPTION="Build foreign function call interfaces in embedded interpreter"
+HOMEPAGE="https://www.gnu.org/software/libffcall/"
+SRC_URI="mirror://gnu/libffcall/${MY_PV}.tar.gz"
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}/${MY_PV}
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # The build system is a strange mix of autogenerated
+ # files and manual tweaks on top. Uses $CFLAGS / $LDFLAGS randomly.
+ # We are adding them consistently here and a bit over the top:
+ # bugs: #334581
+
+ for mfi in {,*/,*/*/,}Makefile.in
+ do
+ elog "Patching '${mfi}'"
+ # usually uses only assembler here, but -march=
+ # and -Wa, are a must to pass here.
+ sed -e 's/$(CC) /&$(CFLAGS) /g' \
+ -i "${mfi}" || die
+ done
+ eapply_user
+}
+
+src_configure() {
+ append-flags -fPIC
+
+ # Doc goes in datadir
+ econf \
+ --datadir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared \
+ --disable-static
+}
+
+src_compile() {
+ # TODO. Remove -j1
+ emake -j1
+}
+
+src_install() {
+ dodoc NEWS README
+ dodir /usr/share/man
+ default
+ prune_libtool_files
+}