summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-12-23 17:17:38 +0100
committerFabian Groffen <grobian@gentoo.org>2017-12-23 17:17:38 +0100
commit82a7b2d795d7e8e7aed2163c930a8228b700c3be (patch)
treefe7605a5d4fe6e2b17f99434357f6473d5982a91 /dev-libs/gnulib/gnulib-2017.12.19.15.53.47.ebuild
parentdev-libs/gnulib: marked ~x64-macos (diff)
downloadgentoo-82a7b2d795d7e8e7aed2163c930a8228b700c3be.tar.gz
gentoo-82a7b2d795d7e8e7aed2163c930a8228b700c3be.tar.bz2
gentoo-82a7b2d795d7e8e7aed2163c930a8228b700c3be.zip
dev-libs/gnulib: add new snapshot, fix dosym usage
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-libs/gnulib/gnulib-2017.12.19.15.53.47.ebuild')
-rw-r--r--dev-libs/gnulib/gnulib-2017.12.19.15.53.47.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/gnulib/gnulib-2017.12.19.15.53.47.ebuild b/dev-libs/gnulib/gnulib-2017.12.19.15.53.47.ebuild
new file mode 100644
index 000000000000..3018a94c51d0
--- /dev/null
+++ b/dev-libs/gnulib/gnulib-2017.12.19.15.53.47.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GIT_TAG="f583f328bec489dd59b54ecc1cc640843ea261cf"
+
+DESCRIPTION="Library of common routines intended to be shared"
+HOMEPAGE="https://www.gnu.org/software/gnulib"
+SRC_URI="https://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${PN}-${GIT_TAG}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc-aix ~x86-fbsd ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+S="${WORKDIR}/${PN}-${GIT_TAG}"
+
+src_compile() {
+ if use doc; then
+ emake -C doc info html
+ fi
+}
+
+src_install() {
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins -r build-aux
+ doins -r doc
+ doins -r lib
+ doins -r m4
+ doins -r modules
+ doins -r tests
+ doins -r top
+
+ # install the real script
+ exeinto /usr/share/${PN}
+ doexe gnulib-tool
+
+ # create and install the wrapper
+ dosym ../share/${PN}/gnulib-tool /usr/bin/gnulib-tool
+}