summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-05-03 02:16:39 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-05-03 02:16:39 +0200
commit4501e2a0ea32d84799ae95861c122315f80dc135 (patch)
treea99fe601471f7ad2e75c9b405a7461a0aa363be1 /dev-libs/json-c/json-c-0.13.1-r1.ebuild
parentsys-kernel/gentoo-sources: Carefully prune 4.14.2X kernels. (diff)
downloadgentoo-4501e2a0ea32d84799ae95861c122315f80dc135.tar.gz
gentoo-4501e2a0ea32d84799ae95861c122315f80dc135.tar.bz2
gentoo-4501e2a0ea32d84799ae95861c122315f80dc135.zip
dev-libs/json-c: Rev bump to update sub slot
v13.1 was a major ABI bump! Package-Manager: Portage-2.3.33, Repoman-2.3.9
Diffstat (limited to 'dev-libs/json-c/json-c-0.13.1-r1.ebuild')
-rw-r--r--dev-libs/json-c/json-c-0.13.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/json-c/json-c-0.13.1-r1.ebuild b/dev-libs/json-c/json-c-0.13.1-r1.ebuild
new file mode 100644
index 000000000000..96f1cb8194fe
--- /dev/null
+++ b/dev-libs/json-c/json-c-0.13.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal ltprune
+
+DESCRIPTION="A JSON implementation in C"
+HOMEPAGE="https://github.com/json-c/json-c/wiki"
+SRC_URI="https://s3.amazonaws.com/json-c_releases/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc static-libs"
+
+src_prepare() {
+ default
+ sed -i -e "s:-Werror::" configure.ac || die
+ eautoreconf
+
+ # tests break otherwise
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ export USE_VALGRIND=0 VERBOSE=1
+ default
+}
+
+multilib_src_install_all() {
+ use doc && HTML_DOCS=( "${S}"/doc/html/. )
+ einstalldocs
+
+ # add symlink for projects not using pkgconfig
+ dosym ../json-c /usr/include/json-c/json
+
+ prune_libtool_files
+}