summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-03 23:54:57 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-04 00:12:22 +0200
commitaab37023f705b100c60a118362ff20236970ad6e (patch)
tree76632c38cb2e0c97b75715e481baf450e11daab6 /dev-libs/libRocket
parentgames-fps/warsow: Remove last-rited pkg (diff)
downloadgentoo-aab37023f705b100c60a118362ff20236970ad6e.tar.gz
gentoo-aab37023f705b100c60a118362ff20236970ad6e.tar.bz2
gentoo-aab37023f705b100c60a118362ff20236970ad6e.zip
dev-libs/libRocket: Remove last-rited pkg
Closes: https://bugs.gentoo.org/558698 Closes: https://bugs.gentoo.org/599224 Closes: https://bugs.gentoo.org/600680
Diffstat (limited to 'dev-libs/libRocket')
-rw-r--r--dev-libs/libRocket/Manifest2
-rw-r--r--dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild96
-rw-r--r--dev-libs/libRocket/libRocket-1.3.0.0.ebuild98
-rw-r--r--dev-libs/libRocket/libRocket-9999.ebuild97
-rw-r--r--dev-libs/libRocket/metadata.xml11
5 files changed, 0 insertions, 304 deletions
diff --git a/dev-libs/libRocket/Manifest b/dev-libs/libRocket/Manifest
deleted file mode 100644
index a0c54f76284a..000000000000
--- a/dev-libs/libRocket/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST libRocket-1.2.1_p20130110.tar.xz 845572 SHA256 5661f0d1b0a3e19b9f2856b9927ed7ec4ad6939e732230832cd701bf078a732b SHA512 1c474e0cad2e13ebe6102cd5d31c3fa61370d23062c31fd7703ec431f0da56f008c9711b49b73d8a9b32af0313e2cb3aa8c46888a36044fef05c15fe1cbc23b5 WHIRLPOOL 52ef88ebc35ac762c6b50fbaed8713b2568f80bc65390e696537f4935eaf1c4182a64b414fd6bfadb3e1a6cadb0589fcb20bc12c26e3ea87edaf342b5ff09bb6
-DIST libRocket-1.3.0.0.tar.gz 1858846 SHA256 574e992ac0bb62c1aa782114986d440ade69f4408971d0fb4ddc5922df761b75 SHA512 579fb5b9ca48b44999ca9c64e5fde3f28b83b12487928d34cf6e2834e60c4fff06c845832d38387f4ba639e2bd906b96940da4ce5e4c73625c48c6658726d3bd WHIRLPOOL a72c72c38780bc4dba9fbdb14365b675579e0a4d251c88bcf780fa076c16728c09c9ba7dff733d8f54da8064184e585ea568e12275f8e7ab86d55333a6242b0f
diff --git a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
deleted file mode 100644
index 9d21accbda41..000000000000
--- a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils eutils python-r1 multilib-minimal
-
-DESCRIPTION="A HTML/CSS User Interface library"
-HOMEPAGE="https://librocket.com/"
-SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="python samples"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
- python? (
- ${PYTHON_DEPS}
- dev-libs/boost[${PYTHON_USEDEP}]
- )
- samples? (
- virtual/opengl
- x11-libs/libXext
- x11-libs/libX11
- )"
-DEPEND="${RDEPEND}"
-
-DOCS=( changelog.txt readme.md )
-
-python_BUILD_DIR=${WORKDIR}/${P}_build_python
-CMAKE_USE_DIR="${S}"/Build
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=OFF
- -DSAMPLES_DIR=/usr/share/${PN}/samples
- )
-
- if multilib_is_native_abi ; then
- mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
- else
- mycmakeargs+=( -DBUILD_SAMPLES=OFF )
- fi
-
- cmake-utils_src_configure
-
- if multilib_is_native_abi ; then
- if use python ; then
- cfgpybind() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=ON
- -DCMAKE_SKIP_RPATH=YES
- )
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
- }
- einfo "configuring python binding"
- python_foreach_impl cfgpybind
- fi
- fi
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- local abi_build_dir=${BUILD_DIR}
-
- if multilib_is_native_abi ; then
- if use python ; then
- buildpybind() {
- cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
- }
- einfo "compiling python binding"
- python_foreach_impl buildpybind
- fi
- fi
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-
- if multilib_is_native_abi ; then
- if use python ; then
- instpybind() {
- python_domodule "${S}"/bin/rocket.py
- exeinto "$(python_get_sitedir)"
- doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
- }
- einfo "installing python binding"
- python_foreach_impl instpybind
- fi
- fi
-}
diff --git a/dev-libs/libRocket/libRocket-1.3.0.0.ebuild b/dev-libs/libRocket/libRocket-1.3.0.0.ebuild
deleted file mode 100644
index a99590e83998..000000000000
--- a/dev-libs/libRocket/libRocket-1.3.0.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils eutils python-r1 multilib-minimal
-
-DESCRIPTION="A HTML/CSS User Interface library"
-HOMEPAGE="https://librocket.com/"
-SRC_URI="https://github.com/libRocket/libRocket/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86"
-IUSE="python samples"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
- python? (
- ${PYTHON_DEPS}
- dev-libs/boost[${PYTHON_USEDEP}]
- )
- samples? (
- virtual/opengl
- x11-libs/libXext
- x11-libs/libX11
- )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${PN}-release-${PV}
-
-DOCS=( changelog.txt readme.md )
-
-python_BUILD_DIR=${WORKDIR}/${P}_build_python
-CMAKE_USE_DIR="${S}"/Build
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=OFF
- -DSAMPLES_DIR=/usr/share/${PN}/samples
- )
-
- if multilib_is_native_abi ; then
- mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
- else
- mycmakeargs+=( -DBUILD_SAMPLES=OFF )
- fi
-
- cmake-utils_src_configure
-
- if multilib_is_native_abi ; then
- if use python ; then
- cfgpybind() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=ON
- -DCMAKE_SKIP_RPATH=YES
- )
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
- }
- einfo "configuring python binding"
- python_foreach_impl cfgpybind
- fi
- fi
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- local abi_build_dir=${BUILD_DIR}
-
- if multilib_is_native_abi ; then
- if use python ; then
- buildpybind() {
- cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
- }
- einfo "compiling python binding"
- python_foreach_impl buildpybind
- fi
- fi
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-
- if multilib_is_native_abi ; then
- if use python ; then
- instpybind() {
- python_domodule "${S}"/bin/rocket.py
- exeinto "$(python_get_sitedir)"
- doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
- }
- einfo "installing python binding"
- python_foreach_impl instpybind
- fi
- fi
-}
diff --git a/dev-libs/libRocket/libRocket-9999.ebuild b/dev-libs/libRocket/libRocket-9999.ebuild
deleted file mode 100644
index 8612a41c005f..000000000000
--- a/dev-libs/libRocket/libRocket-9999.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils git-2 python-r1 multilib-minimal
-
-DESCRIPTION="A HTML/CSS User Interface library"
-HOMEPAGE="https://librocket.com/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/hasufell/libRocket.git"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="python samples"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
- python? (
- ${PYTHON_DEPS}
- dev-libs/boost[${PYTHON_USEDEP}]
- )
- samples? (
- virtual/opengl
- x11-libs/libXext
- x11-libs/libX11
- )"
-DEPEND="${RDEPEND}"
-
-DOCS=( changelog.txt readme.md )
-
-python_BUILD_DIR=${WORKDIR}/${P}_build_python
-CMAKE_USE_DIR="${S}"/Build
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=OFF
- -DSAMPLES_DIR=/usr/share/${PN}/samples
- )
-
- if multilib_is_native_abi ; then
- mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
- else
- mycmakeargs+=( -DBUILD_SAMPLES=OFF )
- fi
-
- cmake-utils_src_configure
-
- if multilib_is_native_abi ; then
- if use python ; then
- cfgpybind() {
- local mycmakeargs=(
- -DBUILD_PYTHON_BINDINGS=ON
- -DCMAKE_SKIP_RPATH=YES
- )
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
- }
- einfo "configuring python binding"
- python_foreach_impl cfgpybind
- fi
- fi
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
- local abi_build_dir=${BUILD_DIR}
-
- if multilib_is_native_abi ; then
- if use python ; then
- buildpybind() {
- cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
- BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
- }
- einfo "compiling python binding"
- python_foreach_impl buildpybind
- fi
- fi
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-
- if multilib_is_native_abi ; then
- if use python ; then
- instpybind() {
- python_domodule "${S}"/bin/rocket.py
- exeinto "$(python_get_sitedir)"
- doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
- }
- einfo "installing python binding"
- python_foreach_impl instpybind
- fi
- fi
-}
diff --git a/dev-libs/libRocket/metadata.xml b/dev-libs/libRocket/metadata.xml
deleted file mode 100644
index 00acc1335772..000000000000
--- a/dev-libs/libRocket/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="samples">Build samples</flag>
- </use>
- <upstream>
- <remote-id type="github">libRocket/libRocket</remote-id>
- </upstream>
-</pkgmetadata>