summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-10-03 10:42:24 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-10-03 11:54:15 -0700
commitff1c6139f946163fd6a90174961d4a2a928dcddc (patch)
tree720cbf4958efcb9dcaaee5d04f1d5011b84d976f /dev-libs/libbpf/files
parentdev-lang/gnat-gpl: fix MissingTestRestrict (diff)
downloadgentoo-ff1c6139f946163fd6a90174961d4a2a928dcddc.tar.gz
gentoo-ff1c6139f946163fd6a90174961d4a2a928dcddc.tar.bz2
gentoo-ff1c6139f946163fd6a90174961d4a2a928dcddc.zip
dev-libs/libbpf: Version bump to 0.0.5
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/libbpf/files')
-rw-r--r--dev-libs/libbpf/files/libbpf-0.0.5-paths.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libbpf/files/libbpf-0.0.5-paths.patch b/dev-libs/libbpf/files/libbpf-0.0.5-paths.patch
new file mode 100644
index 000000000000..e9eda9c2dced
--- /dev/null
+++ b/dev-libs/libbpf/files/libbpf-0.0.5-paths.patch
@@ -0,0 +1,38 @@
+diff --git a/Makefile b/Makefile
+index 6992fbf..cefc77a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -64,7 +64,7 @@ endif
+ PREFIX ?= /usr
+ LIBDIR ?= $(PREFIX)/$(LIBSUBDIR)
+ INCLUDEDIR ?= $(PREFIX)/include
+-UAPIDIR ?= $(PREFIX)/include
++UAPIDIR ?= $(PREFIX)/include/bpf/uapi
+
+ all: $(STATIC_LIBS) $(SHARED_LIBS) $(PC_FILE)
+
+@@ -85,6 +85,7 @@ $(OBJDIR)/libbpf.so.$(LIBBPF_VERSION): $(SHARED_OBJS)
+ $(OBJDIR)/libbpf.pc:
+ sed -e "s|@PREFIX@|$(PREFIX)|" \
+ -e "s|@LIBDIR@|$(LIBDIR)|" \
++ -e "s|@UAPIDIR@|$(UAPIDIR)|" \
+ -e "s|@VERSION@|$(LIBBPF_VERSION)|" \
+ < libbpf.pc.template > $@
+
+diff --git a/libbpf.pc.template b/libbpf.pc.template
+index ac17fce..6d385d9 100644
+--- a/libbpf.pc.template
++++ b/libbpf.pc.template
+@@ -3,10 +3,11 @@
+ prefix=@PREFIX@
+ libdir=@LIBDIR@
+ includedir=${prefix}/include
++uapidir=@UAPIDIR@
+
+ Name: libbpf
+ Description: BPF library
+ Version: @VERSION@
+ Libs: -L${libdir} -lbpf
+ Requires.private: libelf
+-Cflags: -I${includedir}
++Cflags: -I${includedir} -I${uapidir}