summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2019-07-04 21:38:05 -0400
committerSobhan Mohammadpour <sobhan@gentoo.org>2019-07-04 21:39:36 -0400
commite3bb9032d776eb7475f967d8d7cbf3383de5f23e (patch)
treec2cb61cdda3304c43470e867002cb4ecf380ee8b /dev-libs/libgweather
parentnet-p2p/cpuminer-opt: 3.9.5.2 version bump (diff)
downloadgentoo-e3bb9032d776eb7475f967d8d7cbf3383de5f23e.tar.gz
gentoo-e3bb9032d776eb7475f967d8d7cbf3383de5f23e.tar.bz2
gentoo-e3bb9032d776eb7475f967d8d7cbf3383de5f23e.zip
dev-libs/libgweather: 3.32.1 → 3.32.2
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/Manifest1
-rw-r--r--dev-libs/libgweather/libgweather-3.32.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index e8ec36a1a779..e63eb066377b 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -2,3 +2,4 @@ DIST libgweather-3.24.1.tar.xz 3350680 BLAKE2B 9265cb3c280446d5f380f62b60efb5578
DIST libgweather-3.26.2.tar.xz 3409528 BLAKE2B 1c5cdc7125aac8df95e97db8fa1d63bcb06865e70691621bc3a1c0ece2e602862cef9a2a5daa2ebbc5fa7eaefa32bf89507f1eef8fa4eeff294d43132e83fab4 SHA512 75b936f93814005b4317dcb51777036f589f343526428d9a74de96aac1badd4fe81c117184e2bff84a7a3078d6f2a2000e7b63f1e1d80f839b3513cc470fb25b
DIST libgweather-3.28.3.tar.xz 2711240 BLAKE2B 9e55c32485401fa31e5ca5a824f239c373e41c2ef3a1d4442ba4512f102edadaa3452bdc4f4a445ea34e5e24cda23fbf6e1363da5bd49f70018b387f7450cf15 SHA512 7eb98f15b624090ba0959f4ee47c1a2317504a381829cebb949f4104ea9b5c2847a98f95de60a35c5bf1094e500041c53e1afdb265dd2f237bc49db8acbfd6f2
DIST libgweather-3.32.1.tar.xz 2713696 BLAKE2B 496aa07c517ad570ebf54041b8ae14ec5eb5a923a113e1adcf23e5ac9a515ccb5c2dbeb29c923f0abcfc213409ddafbb1747c5ed5a6129bd4ac40b4e0fd687d6 SHA512 f5ae94436fa3cceee84ff80f14296f11ab27727e3881689dd71126de158f7d0015b462163cb2b47cf30add5a4c97c89c6473c1ed0515fcaac0dde2daffdf7108
+DIST libgweather-3.32.2.tar.xz 2716144 BLAKE2B 56bf66edde8293758f49c1ca14b47fb725f72a0202e95e6e1d1832c179fd9414d527827be5cb7daa17627abfbd1ac16d8d09dbdbbdcb24d62cc62c25a220c156 SHA512 61543e5eaf8c04605a91a6f47811b3a0ed2b04c2f50eae9b8d08a4e24904db4731748fa27a0863d2cdab5fde776ec55abe9fd9fb2a72c7bd546665d59957cb4d
diff --git a/dev-libs/libgweather/libgweather-3.32.2.ebuild b/dev-libs/libgweather/libgweather-3.32.2.ebuild
new file mode 100644
index 000000000000..e349e588d0fb
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.32.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Location and timezone database and weather-lookup library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-15" # subslot = 3-(libgweather-3 soname suffix)
+
+IUSE="glade gtk-doc +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=x11-libs/gtk+-3.13.5:3[introspection?]
+ >=net-libs/libsoup-2.44:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ sci-geosciences/geocode-glib
+ >=sys-libs/timezone-data-2010k
+
+ glade? ( >=dev-util/glade-3.16:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.11
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-meson-tweaks.patch # Provide introspection optionality and don't build tests that aren't ran automatically
+)
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use glade glade_catalog)
+ $(meson_use vala enable_vala)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}