summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-07-08 15:27:31 -0500
committerTony Vroon <chainsaw@gentoo.org>2018-07-13 12:16:38 +0100
commitdd77923b4fc5e93da5aba59dd8e261384a8d2041 (patch)
tree73d062892cc60482d5614f3add60320010675edf /dev-libs/libpthread-stubs
parentdev-libs/libevdev: add live ebuild (diff)
downloadgentoo-dd77923b4fc5e93da5aba59dd8e261384a8d2041.tar.gz
gentoo-dd77923b4fc5e93da5aba59dd8e261384a8d2041.tar.bz2
gentoo-dd77923b4fc5e93da5aba59dd8e261384a8d2041.zip
dev-libs/libpthread-stubs: port to EAPI 7
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libpthread-stubs')
-rw-r--r--dev-libs/libpthread-stubs/libpthread-stubs-0.4-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/libpthread-stubs/libpthread-stubs-0.4-r1.ebuild b/dev-libs/libpthread-stubs/libpthread-stubs-0.4-r1.ebuild
new file mode 100644
index 000000000000..594762ecbbf1
--- /dev/null
+++ b/dev-libs/libpthread-stubs/libpthread-stubs-0.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Pthread functions stubs for platforms missing them"
+HOMEPAGE="https://www.x.org/wiki/"
+SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+# there is nothing to compile for this package, all its contents are produced by
+# configure. the only make job that matters is make install
+multilib_src_compile() { true; }