summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-02-07 10:22:26 +0000
committerMarek Szuba <marecki@gentoo.org>2023-02-07 11:14:34 +0000
commita28783c5c768c1dc17399c99e98075ebfba5315e (patch)
tree98602cae5f8667f21b3973fb60555af20e59c769 /dev-libs/mmtf-cpp/mmtf-cpp-1.1.0-r1.ebuild
parentwww-client/falkon: drop 22.04.3-r1 (diff)
downloadgentoo-a28783c5c768c1dc17399c99e98075ebfba5315e.tar.gz
gentoo-a28783c5c768c1dc17399c99e98075ebfba5315e.tar.bz2
gentoo-a28783c5c768c1dc17399c99e98075ebfba5315e.zip
dev-libs/mmtf-cpp: fix msgpack dependency
The upstream README states clearly "You need the headers of the MessagePack C++ library", meaning we should depend either on dev-libs/msgpack[cxx] or, for newer msgpack, on dev-cpp/msgpack-cxx. Note that since msgpack upstream renamed the relevant CMake package from "msgpack" to "msgpackc-cxx" in version 5.0.0, src_configure() can complain. This is harmless though, as the presence or absence of msgpack C++ headers at build time does not affect runtime operation of mmtf-cpp. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/mmtf-cpp/mmtf-cpp-1.1.0-r1.ebuild')
-rw-r--r--dev-libs/mmtf-cpp/mmtf-cpp-1.1.0-r1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-libs/mmtf-cpp/mmtf-cpp-1.1.0-r1.ebuild b/dev-libs/mmtf-cpp/mmtf-cpp-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..909f0a52da9a
--- /dev/null
+++ b/dev-libs/mmtf-cpp/mmtf-cpp-1.1.0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The pure C++ implementation of the MMTF API, decoder and encoder"
+HOMEPAGE="https://github.com/rcsb/mmtf-cpp"
+SRC_URI="https://github.com/rcsb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+DEPEND="|| ( dev-cpp/msgpack-cxx dev-libs/msgpack[cxx(-)] )"
+RDEPEND="${DEPEND}"