summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-19 07:51:09 +0000
committerSam James <sam@gentoo.org>2021-10-19 07:51:09 +0000
commit0797df5c4e2868ed33979b06bae4eff2ba22159e (patch)
treed649cad1d11fd26b64cb06068c6132dfacd45627 /dev-libs/mpfr/mpfr-4.1.0-r1.ebuild
parentapp-antivirus/clamav: use consistent style, misc tidying (diff)
downloadgentoo-0797df5c4e2868ed33979b06bae4eff2ba22159e.tar.gz
gentoo-0797df5c4e2868ed33979b06bae4eff2ba22159e.tar.bz2
gentoo-0797df5c4e2868ed33979b06bae4eff2ba22159e.zip
dev-libs/mpfr: add missing gmp subslot operator
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/mpfr/mpfr-4.1.0-r1.ebuild')
-rw-r--r--dev-libs/mpfr/mpfr-4.1.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/mpfr/mpfr-4.1.0-r1.ebuild b/dev-libs/mpfr/mpfr-4.1.0-r1.ebuild
new file mode 100644
index 000000000000..986919466dde
--- /dev/null
+++ b/dev-libs/mpfr/mpfr-4.1.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Library for multiple-precision floating-point computations with exact rounding"
+HOMEPAGE="https://www.mpfr.org/"
+SRC_URI="https://www.mpfr.org/mpfr-${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/6" # libmpfr.so version
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-5.0.0:=[${MULTILIB_USEDEP},static-libs?]"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/FAQ.html )
+
+multilib_src_configure() {
+ # Make sure mpfr doesn't go probing toolchains it shouldn't #476336#19
+ ECONF_SOURCE=${S} \
+ user_redefine_cc=yes \
+ econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ rm "${ED}"/usr/share/doc/"${P}"/COPYING*
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}