summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-02-21 18:57:00 +0100
committerMike Gilbert <floppym@gentoo.org>2018-02-21 15:32:17 -0500
commit34f2b3a8006ca31bcc03364066ec7dcd68d2950e (patch)
tree173da47d3f2ea2988e153a06939c7b7c52cec862 /dev-libs/protobuf/protobuf-3.5.1.1.ebuild
parentwww-client/chromium: beta channel bump (65.0.3325.73) (diff)
downloadgentoo-34f2b3a8006ca31bcc03364066ec7dcd68d2950e.tar.gz
gentoo-34f2b3a8006ca31bcc03364066ec7dcd68d2950e.tar.bz2
gentoo-34f2b3a8006ca31bcc03364066ec7dcd68d2950e.zip
dev-libs/protobuf: Fix building on IA64.
Closes: https://bugs.gentoo.org/648248
Diffstat (limited to 'dev-libs/protobuf/protobuf-3.5.1.1.ebuild')
-rw-r--r--dev-libs/protobuf/protobuf-3.5.1.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-libs/protobuf/protobuf-3.5.1.1.ebuild b/dev-libs/protobuf/protobuf-3.5.1.1.ebuild
index 4f44ebc4d8c7..97cbe92c9220 100644
--- a/dev-libs/protobuf/protobuf-3.5.1.1.ebuild
+++ b/dev-libs/protobuf/protobuf-3.5.1.1.ebuild
@@ -23,16 +23,21 @@ PATCHES=(
"${FILESDIR}/${PN}-3.4.0-disable_no-warning-test.patch"
"${FILESDIR}/${PN}-3.4.0-system_libraries.patch"
"${FILESDIR}/${PN}-3.4.0-protoc_input_output_files.patch"
+ "${FILESDIR}/${PN}-3.5.0-atomic_operations.patch"
)
DOCS=(CHANGES.txt CONTRIBUTORS.txt README.md)
src_prepare() {
- append-cppflags -DGOOGLE_PROTOBUF_NO_RTTI
default
eautoreconf
}
+src_configure() {
+ append-cppflags -DGOOGLE_PROTOBUF_NO_RTTI
+ multilib-minimal_src_configure
+}
+
multilib_src_configure() {
local myeconfargs=(
$(use_enable static-libs static)