summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-11 21:04:36 -0400
committerSam James <sam@gentoo.org>2024-03-12 02:24:45 +0000
commitba8d8948c6a0b1957fed4b591bd65bd864ac8982 (patch)
treee81dcbd9231ff55e2f2637179febb12a05cf64b8 /dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild
parentdev-libs/rocr-runtime: remove incorrect sed that doesn't apply (diff)
downloadgentoo-ba8d8948c6a0b1957fed4b591bd65bd864ac8982.tar.gz
gentoo-ba8d8948c6a0b1957fed4b591bd65bd864ac8982.tar.bz2
gentoo-ba8d8948c6a0b1957fed4b591bd65bd864ac8982.zip
dev-libs/rocr-runtime: remove another sed that doesn't apply
Upstream changed this whole code around in 5.3.0 via: https://github.com/ROCm/ROCR-Runtime/commit/adae6c61e10d371f7cbc3d0e94ae2c070cab18a4 Since then, this sed has been tweaked in small ways without fundamentally changing the part that doesn't match anymore. Since the sed wasn't tested, I can only assume that the promise about system clang/llvm is outdated. ;) I believe cmake's hints logic should simply work anyway... Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild3
1 files changed, 0 insertions, 3 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild b/dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild
index 6982173e2eb6..36f37da462ab 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-5.5.1.ebuild
@@ -38,9 +38,6 @@ BDEPEND="app-editors/vim-core"
# vim-core is needed for "xxd"
src_prepare() {
- # ... otherwise system llvm/clang is used ...
- sed -e "/find_package(Clang REQUIRED HINTS /s:\${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm:$(get_llvm_prefix ${LLVM_MAX_SLOT}):" -i image/blit_src/CMakeLists.txt || die
-
# Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
sed -e "s:-O2:--rocm-path=${EPREFIX}/usr/lib/ -O2:" -i image/blit_src/CMakeLists.txt || die