summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2020-02-09 17:19:03 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-04-23 10:41:07 +0300
commit90a8f8422285d07017893315229fe0b64fe8807d (patch)
treebdae05c5129be303ee851398c5ce8c7a7f62471c /dev-libs/univalue/univalue-1.0.5.ebuild
parentapp-crypt/swtpm: Remove old (diff)
downloadgentoo-90a8f8422285d07017893315229fe0b64fe8807d.tar.gz
gentoo-90a8f8422285d07017893315229fe0b64fe8807d.tar.bz2
gentoo-90a8f8422285d07017893315229fe0b64fe8807d.zip
dev-libs/univalue: Bump to 1.0.5
Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org> Closes: https://github.com/gentoo/gentoo/pull/15389 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/univalue/univalue-1.0.5.ebuild')
-rw-r--r--dev-libs/univalue/univalue-1.0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/univalue/univalue-1.0.5.ebuild b/dev-libs/univalue/univalue-1.0.5.ebuild
new file mode 100644
index 000000000000..5c07a1e07b00
--- /dev/null
+++ b/dev-libs/univalue/univalue-1.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C++ universal value object and JSON library"
+HOMEPAGE="https://github.com/jgarzik/univalue"
+SRC_URI="https://codeload.github.com/jgarzik/${PN}/tar.gz/v${PV} -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}