summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-07 17:13:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-07 20:06:14 +0100
commit7a998120a35d70a277a5f696a5b0c54e55f77d02 (patch)
treeff74f1bf2397c80f9236c42dbeec1bcbfe3a7ba4 /dev-libs
parentdev-libs/kopeninghours: 24.08.3 version bump (diff)
downloadgentoo-7a998120a35d70a277a5f696a5b0c54e55f77d02.tar.gz
gentoo-7a998120a35d70a277a5f696a5b0c54e55f77d02.tar.bz2
gentoo-7a998120a35d70a277a5f696a5b0c54e55f77d02.zip
dev-libs/kosmindoormap: 24.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kosmindoormap/Manifest1
-rw-r--r--dev-libs/kosmindoormap/kosmindoormap-24.08.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/kosmindoormap/Manifest b/dev-libs/kosmindoormap/Manifest
index a0860b356613..9ff2d5865920 100644
--- a/dev-libs/kosmindoormap/Manifest
+++ b/dev-libs/kosmindoormap/Manifest
@@ -1,2 +1,3 @@
DIST kosmindoormap-24.08.1.tar.xz 691904 BLAKE2B 015200603e441d81685fb7e09738a75901e4035c7e60aa1473663218436c62d9a6166e976fda4ef5219f8a541d2a1495cb5a5746df5b255f3db78f6a44649fe7 SHA512 1ad9cf7678b97847dc0482530f94173b8facfbcf8dc6dfe9e13214bfd5b1b02a3a8ddbca357e9dd7a37296052130bde958765fc04062d2f7f5680d4e103b8cc5
DIST kosmindoormap-24.08.2.tar.xz 691860 BLAKE2B c28e60fa7124d529d523fca52f6387f47a22ae7b187620bf94863ffbe93653d9b90f62aa13a12703a080b68035f981b099c2a2c51c2b18859eb0b05c3bf214b7 SHA512 955f9eafd93e7c1203799693f862e7d5f2c7b37261588cafe484c0538fd10e1966ed1a901592a8bc8c9422da2af0746b4b6cc49200b28b053042e36167e03c1d
+DIST kosmindoormap-24.08.3.tar.xz 692392 BLAKE2B 41879a7ef4dbde858d8e6f2e53b4b32efd94f4277ed8bf6c9d4343907364814acc00cc5bdf09840e429e7fd4cf2150d535dcb261ae7debcc0c941837b1607385 SHA512 cf63d91306d41d8fd9cc3c33eee91a6380a0d043a610b49b214dfb8de76531dacf03e2745d1783e4627b218e6bf55b370d1946b6e4276aea10906d790d63f881
diff --git a/dev-libs/kosmindoormap/kosmindoormap-24.08.3.ebuild b/dev-libs/kosmindoormap/kosmindoormap-24.08.3.ebuild
new file mode 100644
index 000000000000..917524a82c30
--- /dev/null
+++ b/dev-libs/kosmindoormap/kosmindoormap-24.08.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
+HOMEPAGE="https://invent.kde.org/libraries/kosmindoormap"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+gui"
+
+# kservice is optional and only used to find and open josm
+RDEPEND="
+ dev-libs/protobuf:=
+ >=dev-qt/qtbase-${QTMIN}:6[gui?,network]
+ sys-libs/zlib
+ gui? (
+ >=dev-libs/kopeninghours-${PVCUT}:6
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtbase-${QTMIN}:6[widgets] )
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TOOLS_ONLY=$(usex !gui)
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ )
+ ecm_src_configure
+}