summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:12:40 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:30 +0100
commit87d5541a12bafe2f12574cc735b9e40d6b0ab1ed (patch)
tree72063ccf8c67dea2b8f60ba4cb9843fc55b5a940 /dev-lua/busted
parentdev-lua/LuaBitOp: drop 1.0.2-r103 (diff)
downloadgentoo-87d5541a12bafe2f12574cc735b9e40d6b0ab1ed.tar.gz
gentoo-87d5541a12bafe2f12574cc735b9e40d6b0ab1ed.tar.bz2
gentoo-87d5541a12bafe2f12574cc735b9e40d6b0ab1ed.zip
dev-lua/busted: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/busted')
-rw-r--r--dev-lua/busted/busted-2.0.0-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-lua/busted/busted-2.0.0-r1.ebuild b/dev-lua/busted/busted-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..4629e0305062
--- /dev/null
+++ b/dev-lua/busted/busted-2.0.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Elegant Lua unit testing"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+ dev-lua/luasystem[${LUA_USEDEP}]
+ dev-lua/dkjson[${LUA_USEDEP}]
+ dev-lua/say[${LUA_USEDEP}]
+ dev-lua/luassert[${LUA_USEDEP}]
+ dev-lua/lua-term[${LUA_USEDEP}]
+ dev-lua/penlight[${LUA_USEDEP}]
+ dev-lua/mediator_lua[${LUA_USEDEP}]
+ ${LUA_DEPS}
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-lua/busted
+ ${RDEPEND}
+ )
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins -r busted
+}
+
+src_install() {
+ dobin bin/busted
+
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}