summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/bin-prot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/bin-prot')
-rw-r--r--dev-ml/bin-prot/Manifest3
-rw-r--r--dev-ml/bin-prot/bin-prot-112.17.00.ebuild28
-rw-r--r--dev-ml/bin-prot/bin-prot-112.24.00.ebuild28
-rw-r--r--dev-ml/bin-prot/bin-prot-112.35.00.ebuild28
-rw-r--r--dev-ml/bin-prot/metadata.xml5
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-ml/bin-prot/Manifest b/dev-ml/bin-prot/Manifest
new file mode 100644
index 000000000000..f50936194d6b
--- /dev/null
+++ b/dev-ml/bin-prot/Manifest
@@ -0,0 +1,3 @@
+DIST bin_prot-112.17.00.tar.gz 94952 SHA256 cd09c9eb5c347dea2f58cc0986ff87f5f575b5b6a8365d0ec97391c7d90f5395 SHA512 e2e9b24e4fd7169024adb00c76ad6580c8fef9985e1447f94d89b374b46e79d51c4849412991a81b711d08f48b076d33a296a86aacb045bac46fcb4d2a9fcd8b WHIRLPOOL fb707a65a661cb665310163824778942d831ad003453647a4f5dea72a895faa74b2ec7e362940ca45065a9a3f7cb9bf11913474161c47e59f80b650683c5a1db
+DIST bin_prot-112.24.tar.gz 95085 SHA256 dc0c978a825c7c123990af3317637c218f61079e6f35dc878260651084f1adb4 SHA512 4495349db1ad8a09a404c354415afc3c8f719ba8bd0e792aedef60c92b2f2222d91dba1cbf5d117cbd08ac14674d6cd1733667cab6f16a5cd738eca6d2ec4ef1 WHIRLPOOL c825db972508d404188ced258cb6d96d6c86140b4e12697586b3cdbd1997b4651ef1bb452edb92f44fec31afb17df952891a1fa4d475d33f8147cc131bf63eae
+DIST bin_prot-112.35.00.tar.gz 97483 SHA256 e97034e9548fa669decc0d386f1b52952a645d0f70297389b60e78ddef35bbbf SHA512 7958e315fd16528bedcdee541b6c7cdc2e088eb79eec5fda676fa72d3b57ddd495f203ad9d27cddf50b5aa3d98b00737b217ae6932d21617ce82ec7a1c4ada8c WHIRLPOOL 509fc7d0fffc9d3ecceb71c389c3f630407897daf75e8fa19c229a43bb23813a767bc1018f873f79a57bc4564740d630f061a40fd459ee11a67fabdfc744197a
diff --git a/dev-ml/bin-prot/bin-prot-112.17.00.ebuild b/dev-ml/bin-prot/bin-prot-112.17.00.ebuild
new file mode 100644
index 000000000000..fc9acbc3d919
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-112.17.00.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-ml/type-conv-109.28.00:=
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+
+DOCS=( "README.md" "CHANGES.md" )
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/bin-prot/bin-prot-112.24.00.ebuild b/dev-ml/bin-prot/bin-prot-112.24.00.ebuild
new file mode 100644
index 000000000000..78442d745fcf
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-112.24.00.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P%.*}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-ml/type-conv-109.28.00:=
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+
+DOCS=( "README.md" "CHANGES.md" )
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/bin-prot/bin-prot-112.35.00.ebuild b/dev-ml/bin-prot/bin-prot-112.35.00.ebuild
new file mode 100644
index 000000000000..fc9acbc3d919
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-112.35.00.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-ml/type-conv-109.28.00:=
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+
+DOCS=( "README.md" "CHANGES.md" )
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/bin-prot/metadata.xml b/dev-ml/bin-prot/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/bin-prot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>