summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2020-02-17 08:34:56 +0100
committerTupone Alfredo <tupone@gentoo.org>2020-02-17 08:34:56 +0100
commit1fc431bc2806da596754fb525faab6b9f7690116 (patch)
tree812e9bc269bbb2ae9dd79219154c696f6493c973 /dev-ml/camlzip/camlzip-1.10.ebuild
parentsci-electronics/iverilog: fix 10.3 gcc-10 build problem (diff)
downloadgentoo-1fc431bc2806da596754fb525faab6b9f7690116.tar.gz
gentoo-1fc431bc2806da596754fb525faab6b9f7690116.tar.bz2
gentoo-1fc431bc2806da596754fb525faab6b9f7690116.zip
dev-ml/camlzip: Version bump to 1.10
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/camlzip/camlzip-1.10.ebuild')
-rw-r--r--dev-ml/camlzip/camlzip-1.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/camlzip/camlzip-1.10.ebuild b/dev-ml/camlzip/camlzip-1.10.ebuild
new file mode 100644
index 000000000000..3c6a128e841c
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+ dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a
+
+ dodoc README Changes
+}