summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-11-03 22:39:06 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-11-03 22:39:06 +0100
commit33f9cd3dcc8db810ca6a1fb7dafc3bc3637d6c33 (patch)
treeda0dd6bba64f02573182b3f0f01d3ce6a91411fd /dev-ml/fmt/fmt-0.9.0.ebuild
parentdev-util/gn: bump to 0.1943, EAPI 8 (diff)
downloadgentoo-33f9cd3dcc8db810ca6a1fb7dafc3bc3637d6c33.tar.gz
gentoo-33f9cd3dcc8db810ca6a1fb7dafc3bc3637d6c33.tar.bz2
gentoo-33f9cd3dcc8db810ca6a1fb7dafc3bc3637d6c33.zip
dev-ml/fmt: bump 0.9.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/fmt/fmt-0.9.0.ebuild')
-rw-r--r--dev-ml/fmt/fmt-0.9.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/fmt/fmt-0.9.0.ebuild b/dev-ml/fmt/fmt-0.9.0.ebuild
new file mode 100644
index 000000000000..2c981562f8e6
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib opam
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="https://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="https://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt]
+ >=dev-lang/ocaml-4.08:=[ocamlopt]
+ dev-ml/result:=[ocamlopt]
+ dev-ml/stdlib-shims:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test _build/test/test.native || die
+}