summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-24 10:55:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-24 11:15:16 +0200
commite12a747bf1ee53690e63e7c78e5a24e4eae59b4d (patch)
treef606b425fc8dd81ffb07e4c9d3312291e36648b1 /dev-ml/markup/markup-0.7.2.ebuild
parentmedia-libs/elles_icc_profiles: new package. (diff)
downloadgentoo-e12a747bf1ee53690e63e7c78e5a24e4eae59b4d.tar.gz
gentoo-e12a747bf1ee53690e63e7c78e5a24e4eae59b4d.tar.bz2
gentoo-e12a747bf1ee53690e63e7c78e5a24e4eae59b4d.zip
dev-ml/markup: initial import; ebuild by me
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ml/markup/markup-0.7.2.ebuild')
-rw-r--r--dev-ml/markup/markup-0.7.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/markup/markup-0.7.2.ebuild b/dev-ml/markup/markup-0.7.2.ebuild
new file mode 100644
index 000000000000..235c575c1fb4
--- /dev/null
+++ b/dev-ml/markup/markup-0.7.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/lwt:=[ocamlopt]
+ dev-ml/uutf:=[ocamlopt]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/ocamlbuild"
+S="${WORKDIR}/${PN}.ml-${PV}"
+
+src_compile() {
+ emake
+ use doc && emake docs
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+ use doc && dohtml doc/html/*
+}